Bug Hunting Session
Bug 61392 - VIEWING: [Template Manager]Icons set: icons do not "follow" choice made in Tools> Options> LibreOffice> View
Summary: VIEWING: [Template Manager]Icons set: icons do not "follow" choice made in To...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.1.1 rc
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-24 11:35 UTC by pierre-yves samyn
Modified: 2016-06-17 07:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Image showing icon style/size mis-match. (27.24 KB, image/png)
2013-10-02 18:01 UTC, Paul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2013-02-24 11:35:08 UTC
Hello

Icons (Save, for example) do not "follow" choice made in Tools> Options> LibreOffice> View

Regards
Pierre-Yves
Operating System: All
Version: 4.0.1.1 rc
Comment 1 Jacques Guilleron 2013-02-24 15:16:23 UTC
Confirmed with LO 4.0.1.1, Windows 7 Home Premium.

Regards

Jacques Guilleron
Comment 2 Cor Nouws 2013-03-02 22:57:00 UTC
Hi Pierre-Yves
thanks for the issue(s).
Do not be afraid to add some more words to the summary pls - is helpful of the issue to get a good impression at a first glance :-)
Comment 3 Paul 2013-10-02 18:01:56 UTC
Created attachment 86981 [details]
Image showing icon style/size mis-match.
Comment 4 Paul 2013-10-02 18:03:04 UTC
This behaviour is present still in LibreOffice 4.0.5-2.1

Options => LibreOffice => View "Icon size and style" set to "Small" and "Oxygen".

Attached image shows Template Manager Icons not following that setting, also ignores my Global (KDE) setting of "Icons Only".


openSUSE 12.3 x86_64 (Kernel Release 3.7.10-1.16-desktop) 
KDE 4.11.2
~$ libreoffice --version = LibreOffice 4.0-5
Vendor: obs://build.opensuse.org/LibreOffice
libreoffice-4.0.3.3.5-2.1 (Sat 06 Jul 2013)
libreoffice-icon-themes-4.0.3.3.5-6.1 (Thu 04 Jul 2013)
Comment 5 Francisco 2015-05-03 04:25:42 UTC
Paul,

I have made a custom "oxygen" icon theme for LibO 4.3, replacing some icons in template manager with original Oxygen icons by hand. Sadly, it only works well with LibO 4.3. For another version, some extra work must be done.

If you are interested, it's in kde-look:
http://kde-look.org/content/show.php/Oxygen+for+LibreOffice+4.3?content=168984
Comment 6 Samuel Mehrbrodt (CIB) 2016-06-17 07:12:41 UTC
No longer valid with the revamped template manager.
The icon theme is considered.

However, the icon size setting affects only the toolbars within the main frame, not toolbars used in dialogs. That's not a bug, but intentional.