Bug 61405 - LibreOffice unable to paste image from clipboard
Summary: LibreOffice unable to paste image from clipboard
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-24 19:12 UTC by oc-spam65
Modified: 2016-04-16 10:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oc-spam65 2013-02-24 19:12:21 UTC
To repeat the problem:

* Capture a region from your screen with a tool like "xfce4-screenshooter"
* Do "copy to clipboard"
* Then try to paste in LibreOffice with CTRL+v

Result : LibreOffice stops running during 8 seconds, and nothing is pasted.

Expected result : Screen capture should be pasted, of course.

Note that the mentioned screen capture can be pasted into Gimp without any issue with CTRL+v... This shows that LibreOffice is not functional.
Comment 1 Adolfo Jayme 2013-02-25 16:20:26 UTC
I can’t reproduce this problem in Ubuntu 13.04, LibreOffice 4.0.0, GNOME: after taking a screenshot with gnome-screenshot, clicking “Copy to Clipboard”, switching to LibreOffice Writer and pressing Ctrl+V, the image is immediately pasted. You don’t specify it, what’s your LibreOffice and xfce version?
Comment 2 oc-spam65 2013-02-25 19:21:41 UTC
Hi, thank you for trying.

* The LO version was specified above: 3.5.4 (Debian Testing)
* XFCE: xfce4-session 4.8.3 (Xfce 4.8) and xfce4-screenshooter 1.8.1
Comment 3 mossman44 2013-03-14 13:40:02 UTC
I was able to reproduce the problem in Ubuntu 12.04.2 Libreoffice 4.0.1.2 xfce 4.8. However, when I switched to Unity and tried to paste an image from the clip board, I experienced no issues. This leads me to believe this potential bug is xfce specific.
Comment 4 Alla Bezroutchko 2013-05-08 13:09:33 UTC
I have the same problem on Xubuntu 12.04. The problem is present in LibreOffice 3.5.7.2 and 4.0.2.2.

Copying in xfce4-screenshooter and pasting into Writer does not work. Copying from screenshooter to Gimp, than from Gimp to Writer works. In both cases if I do Paste Special in LibreOffice I see "Bitmap" in the list of available formats.
Comment 5 Jorendc 2013-05-19 12:28:34 UTC
Hi,

Thanks for reporting.

I can not reproduce this using Linux Mint 15 x64 (Cinnamon) with LibreOffice Versie 4.0.3.3 .3.3 (Bouw-id: 400m0(Build:3)); Dutch UI;

I tested both "xfce-screenshooter (1.8.1" as well as "Shutter". I can paste correctly an image to LibreOffice.

@Bug reporter and Alla: you have the chance to reproduce this using a non-xfce interface Linux? I mean, I can not reproduce this using Cinnamon.

Otherwise I'm struggling with the fact this is a LibreOffice bug or not. It is also possible there is something different/wrong/... with the clipboard of xfce interface linux's. But, because Alla reproduced this one, lets mark it as NEW for now. I hope a developer can determine it's a bug in LibreOffice or not.

Kind regards,
Joren
Comment 6 retired 2013-05-19 12:32:33 UTC
Just FYI: Here's the xfce bugtracker clipboard related bugs: maybe add this link and not our bug? https://bugzilla.xfce.org/buglist.cgi?query_format=specific&order=relevance+desc&bug_status=__open__&product=&content=clipboard

Maybe create a bug with them and see if they can verify it as theirs.
Comment 7 gibi 2013-11-04 18:56:42 UTC
Same issue with Linux Mint 15 Xfce Edition 64:
-  xfce4-screenshooter                         1.8.1-1                                amd64
-  xfce4-session                                     4.10.0-2ubuntu1.1                      amd64  
- libreoffice 4.1.3 official X86_64
Comment 8 antistress 2014-03-31 22:51:00 UTC
I can confirm this bug on my Debian Sid GNOME 64 bits system with Libreoffice 1:4.1.5-2

Copy a text within LibreOffice Writer.
Then copy an image from LibreOffice Writer or Firefox
Then try to paste the image to LibreOffice Writer : the text is copied, not the image.

Thanks
Comment 9 Ben M 2014-05-13 19:38:28 UTC
I can confirm I have the same problem on my versions.  Copying to clipboard from a screenshot and pasting into LibreOffice does not work as intended.

LibreOffice: 4.1.3.2  Build410m0(Build:2)
xfce4-screenshooter: 1.8.1-2
xfce4-session: 4.10.1-1ubuntu1
Comment 10 Ioannis A 2014-12-20 00:53:57 UTC
Can confirm the issue exists with i3 (http://i3wm.org/) on Debian Jessie x86_64 with Libreoffice 4.3.3.2.
Comment 11 QA Administrators 2015-12-20 16:18:00 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 12 oc-spam65 2016-04-16 10:06:29 UTC
It apparently works now on my system (Debian):

  LibreOffice Version: 5.0.5.1
  xfce4-screenshooter     1.8.1-2
  xfce4-session   4.10.1-5