Bug 61407 - Wrong font size on screen
Summary: Wrong font size on screen
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-24 19:35 UTC by oc-spam65
Modified: 2013-03-23 21:46 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Minimal ODP example (300.17 KB, application/vnd.oasis.opendocument.presentation)
2013-02-24 19:35 UTC, oc-spam65
Details
Screenshot (217.06 KB, image/png)
2013-02-24 19:37 UTC, oc-spam65
Details

Note You need to log in before you can comment on or make changes to this bug.
Description oc-spam65 2013-02-24 19:35:56 UTC
Created attachment 75455 [details]
Minimal ODP example

In this document, the texts are all "Arial 32", but they are not displayed with the same size on screen. Obviously this is a bug.
Comment 1 oc-spam65 2013-02-24 19:37:10 UTC
Created attachment 75456 [details]
Screenshot

The problem can even be seen on the preview panel on the left in the attached PNG screenshot.
Comment 2 oc-spam65 2013-02-24 19:39:56 UTC
Note about the attachments: the first is an ODP file, the second is a PNG file. The web site apparently removed the extension or whatever. Again a great improvement form Libre/OpenOffice... When will they stop adding bugs all the time?
Comment 3 Adolfo Jayme 2013-02-25 16:38:09 UTC
(In reply to comment #0)
> In this document, the texts are all "Arial 32", but they are not displayed
> with the same size on screen. Obviously this is a bug.

No, it’s NOT obvious. For example, I don’t know about your OS, DPI/screen settings, ...

I recommend that you read “How to report bugs effectively” http://www.chiark.greenend.org.uk/~sgtatham/bugs.html

(In reply to comment #2)
> Note about the attachments: the first is an ODP file, the second is a PNG
> file. The web site apparently removed the extension or whatever. Again a
> great improvement form Libre/OpenOffice... When will they stop adding bugs
> all the time?

Please, dude, relax! This is the freedesktop.org’s instance of Bugzilla, a software which clearly shows the MIME type of attachments, making extensions unnecessary. I bet you will never in your lifetime will find a single piece of software without bugs. Now, let’s focus in not dumping unrelated/unfair/unpleasant rants over here and focus on the font bug instead. OK? </off-topic>
Comment 4 oc-spam65 2013-02-25 19:35:29 UTC
> No, it’s NOT obvious. For example, I don’t know about your OS, DPI/screen
> settings, ...

On the screenshot, you can see that the preview of the two pages do not show the same size for the writing on the two pages. Isn't it inconsistent with the fact that all the texts are written with "Arial 32"?

> (In reply to comment #2)
> > Note about the attachments: the first is an ODP file, the second is a PNG
> > file. The web site apparently removed the extension or whatever. Again a
> > great improvement form Libre/OpenOffice... When will they stop adding bugs
> > all the time?
> 
> Please, dude, relax! This is the freedesktop.org’s instance of Bugzilla, a
> software which clearly shows the MIME type of attachments, making extensions
> unnecessary. 

I don't see the use of this, but if someone saw it, he could have at least set "auto-detect" as the default behavior, instead of forcing everybody to do a supplementary action when uploading a file. </off-topic>
Comment 5 A (Andy) 2013-03-23 21:18:27 UTC
not reproducible with LO 4.0.1.2 (Win7 Home, 64bit)

In my view this is not a bug.  Of course, I can confirm that the texts on both slides have the font size ARIAL 32, but look different on the slides.  The reason is that the text on the first slide shows ARIAL 32, but it is not ARIAL 32 as one could suppose, but smaller.  The reason for this is that the text boxes in both slides have an activated AUTOFIT TEXT function, which adjusts automatically the text sizes to the sizes of the text boxes.  In this case you will have to select the text box on the first slide with a right mouse click and then deactivate the AUTOFIT TEXT function.  Alternatively you can enlarge the text box.  Afterwards, you can see the same text sizes.

Therefore, I have marked it as RESOLVED / NOTABUG.  If this a mistake and not true, please reopen it.
Comment 6 oc-spam65 2013-03-23 21:46:19 UTC
You are right. Thank you for the explanation. I discovered the "autofit text".
This feature is probably useful for some people, but also misleading for others.
Now I need to find how to disable it by default...