Bug Hunting Session
Bug 61410 - FILESAVE: Save 2-page ODT with Record Changes gets 6-page DOC
Summary: FILESAVE: Save 2-page ODT with Record Changes gets 6-page DOC
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab4.3
  Show dependency treegraph
 
Reported: 2013-02-24 20:55 UTC by J David Eisenberg
Modified: 2015-06-19 04:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Original ODT file (34.27 KB, application/vnd.oasis.opendocument.text)
2013-02-24 20:55 UTC, J David Eisenberg
Details
Original document, saved in MS .doc format (40.00 KB, application/msword)
2013-02-24 20:56 UTC, J David Eisenberg
Details
Original document, saved in MS .docx format (13.34 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-02-24 20:57 UTC, J David Eisenberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description J David Eisenberg 2013-02-24 20:55:59 UTC
Created attachment 75458 [details]
Original ODT file

Step 1: Open original.odt
Step 2: Save as docformat.doc (Microsoft , and re-open in LibreOffice. File expands from 2 to 6 pages, and bulleted lists render incorrectly.
Step 3: Open original.odt
Step 4: Save as docxformat.docx, and re-open in LibreOffice. File expands from 2 to 6 pages, and renders with strikethroughs.

Note: If you turn on "show changes" in the original document, you will see it much as it renders after saving in .docx format.
Comment 1 J David Eisenberg 2013-02-24 20:56:48 UTC
Created attachment 75459 [details]
Original document, saved in MS .doc format
Comment 2 J David Eisenberg 2013-02-24 20:57:23 UTC
Created attachment 75460 [details]
Original document, saved in MS .docx format
Comment 3 Joel Madero 2013-02-25 04:55:02 UTC
Verified on:
Version 3.6.4.3 (Build ID: 2ef5aff)
Bodhi Linux 2.2

Changing version to reflect oldest confirmed version with the problem. 

@J David - version is oldest version, we use comments to say we've tested on a newer version.
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Marking as:
New (confirmed)
Major (agree with this, leaving)
High (default for major bugs is high, think this is appropriate here)
Comment 4 J David Eisenberg 2013-02-26 02:04:37 UTC
This seems to reproduce the bug, at least for saving as .docx

1) Open a file in Writer, add some lines; save as .odt and close.
2) Re-open file. Turn on Edit/Changes/Show (should already be on) and Edit/Changes/Record. Save and close
3) Re-open file. Make some edits, then turn off Edit/Changes/Show but leave Edit/Changes/Record on. Save and close.
4) Re-open file. Save as .doc, then save as .docx, then close.
5) Depending upon your changes, the .doc will show some differences; the .docx will show all the changes.
Comment 5 Timur 2014-10-03 14:10:00 UTC
Changed title from "Save .odt as .doc or .docx corrupts word processing file" to "Save ODT as DOC or DOCX turns on Show Changes when Record Changes also on"
Comment 6 tommy27 2014-10-20 12:26:58 UTC
@Timur
please tell which is the latest LibO release where you reproduce the bug.
4.2.6.3 or 4.3.2.2?
Comment 7 Timur 2014-10-20 12:59:29 UTC
I reproduced the bug both for 4.2.6.3 and 4.3.2.2, but only for DOCX, although the title also says DOC.
Comment 8 tommy27 2014-10-20 13:05:27 UTC
@Timur
maybe the bug has been resolved meanwhile in DOC format and persists only with DOCX

@J David Eisenberg
are you still seeing this issue with DOC or just DOCX?
if not, please remove DOC from summary notes
Comment 9 Björn Michaelsen 2014-11-28 09:45:19 UTC
(This is an automated message.)

Setting priority to highest as this is a MAB. This is part of an effort to make the importance of MAB reflected in priority too.
Comment 10 Justin L 2015-01-03 18:44:24 UTC
I reproduced this for both DOC and DOCX.  Ubuntu 12.04 based release, LibreOffice 4.3.5
Comment 11 Timur 2015-03-13 14:17:38 UTC
Since the resulting DOC and DOCX are not the same, I will split this bug into 2, this one for DOC problem with specific attachment 75458 [details], and other one for general DOCX problem - Bug 89991.
I revert the title to "Save 2-page ODT with Record Changes gets 6-page DOC" and set as "inherited".
Comment 12 tommy27 2015-06-18 20:50:37 UTC
retested under Win8.1 x64
LibO 4.3.5.2 still shows the "2 to 6 page" .doc filesave issue.
LibO 4.4.2.3 has no such a bug... the .doc output is still 2 pages.

in the meantime I set status to RESOLVED WORKSFORME

there are some issues left (like page numbers shown as "11" and "22" instead of "1" and "2", and size of the bullets but these have to be reported as different bugs)

however I think that rather than a FILESAVE issue this is a FILEOPEN bug since the .doc file saved in 4.3.x is shown with 6 pages in 4.3.x and with 2 pages in 4.4.x
Comment 13 tommy27 2015-06-19 04:36:52 UTC
for the record I opened Bug 92165 - page numbers doubled (i.e. 1 -> 11; 2 -> 22 etc) after saving .odt as .doc