Bug Hunting Session
Bug 61495 - Indentation difference for Backspace and Shift+Enter after conversion to .doc/.docx
Summary: Indentation difference for Backspace and Shift+Enter after conversion to .doc...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists DOC-Bullet-Number-Lists
  Show dependency treegraph
 
Reported: 2013-02-26 09:27 UTC by Maciej Rumianowski
Modified: 2018-11-04 00:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Side-By-Side difference (138.20 KB, image/png)
2013-02-26 09:27 UTC, Maciej Rumianowski
Details
.odt File with Identation (10.12 KB, application/vnd.oasis.opendocument.text)
2013-02-26 09:29 UTC, Maciej Rumianowski
Details
Converted Indent-Bug.odt -> .doc (10.00 KB, application/msword)
2013-02-26 09:29 UTC, Maciej Rumianowski
Details
Converted Indent-Bug.odt -> .docx (4.70 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-02-26 09:29 UTC, Maciej Rumianowski
Details
docx file to test what Word creates (13.87 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-03-02 22:52 UTC, Cor Nouws
Details
same file, saved as .odt in Word2012 (5.73 KB, application/3dr)
2013-03-02 22:53 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Rumianowski 2013-02-26 09:27:06 UTC
Created attachment 75562 [details]
Side-By-Side difference

Indentation is being lost after conversion to .doc or .docx file if indentation was made with Backspace.

Steps to reproduce:
1. Create .odt file with Bullets
2. Indent with shift+enter or backspace
3. Save As .doc/.docx
4. Close and Open .doc/.docx file
5. Backspace Indentation is lost
Comment 1 Maciej Rumianowski 2013-02-26 09:29:03 UTC
Created attachment 75564 [details]
.odt File with Identation
Comment 2 Maciej Rumianowski 2013-02-26 09:29:29 UTC
Created attachment 75565 [details]
Converted Indent-Bug.odt -> .doc
Comment 3 Maciej Rumianowski 2013-02-26 09:29:47 UTC
Created attachment 75566 [details]
Converted Indent-Bug.odt -> .docx
Comment 4 Brenda Granados 2013-02-26 16:05:36 UTC
I cannot reproduce this behavior using LibreOffice Version 4.0.1.0+ on Ubuntu 12.04. I followed the format of a bulleted list as you created it, using shift + enter or the space bar to indent. After I close and reopen the .doc and .docx, the formatting is still the same between either of those and the original .odt document.

I will close this as WORKSFORME, but if it's still a bug for you, or if you have other info or scenarios about this occurence, you can REOPEN.
Comment 5 Maciej Rumianowski 2013-02-26 20:48:02 UTC
Reproduced using Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Ubuntu 12.10

It is Backspace not space bar. I indent with Backspace as follow: 
1. Hit Enter (Automatically new Bullet is inserted)
2. Hit Backspace (<-) Bullet disappears
Comment 6 Brenda Granados 2013-02-27 15:35:56 UTC
My mistake, thanks for commenting again. I see that when you use the backspace to erase the bullet, the .docx and .doc files don't retain the formatting. This was confirmed using LibreOffice 4.0.1.0+ on Ubuntu 12.04. Thank you for reporting this!
Comment 7 Maciej Rumianowski 2013-03-01 13:31:29 UTC
I've done some more research, below are differences in flat odt files.
Indent-Bug.fodt:
<text:list xml:id="list1342197654" text:style-name="L1">
    <text:list-item>
     <text:p text:style-name="P2">Test1</text:p>
     <text:list>
      <text:list-item>
       <text:p text:style-name="P3">Test2<text:line-break/>Indent <text:span text:style-name="T1">(Shift+Enter)</text:span><text:line-break/>Indent <text:span text:style-name="T1">(Shift+Enter)</text:span></text:p>
      </text:list-item>
      <text:list-item>
       <text:p text:style-name="P2">Test2</text:p>
       <text:p text:style-name="P2">Indent <text:span text:style-name="T1">(Backspace)</text:span></text:p>
       <text:p text:style-name="P3">Indent <text:span text:style-name="T1">(Backspace)</text:span></text:p>
      </text:list-item>
     </text:list>
    </text:list-item>
    <text:list-item>
     <text:p text:style-name="P3">Test1<text:line-break/>Indent <text:span text:style-name="T1">(Shift+Enter)</text:span></text:p>
     <text:p text:style-name="P3">Indent <text:span text:style-name="T1">(Backspace)</text:span></text:p>
    </text:list-item>
    <text:list-item>
     <text:p text:style-name="P2">Test1</text:p>
    </text:list-item>
   </text:list>
Indent-Bug2.fodt (this was done odt->docx->fodt):
<text:list xml:id="list4803795411" text:style-name="WWNum1">
    <text:list-item>
     <text:p text:style-name="P2">Test1</text:p>
     <text:list>
      <text:list-item>
       <text:p text:style-name="P2">Test2<text:line-break/>Indent (Shift+Enter)<text:line-break/>Indent (Shift+Enter)</text:p>
      </text:list-item>
      <text:list-item>
       <text:p text:style-name="P2">Test2</text:p>
      </text:list-item>
     </text:list>
    </text:list-item>
   </text:list>
   <text:p text:style-name="Standard">Indent (Backspace)</text:p>
   <text:p text:style-name="Standard">Indent (Backspace)</text:p>
   <text:list xml:id="list2091705632" text:continue-numbering="true" text:style-name="WWNum1">
    <text:list-item>
     <text:p text:style-name="P2">Test1<text:line-break/>Indent (Shift+Enter)</text:p>
    </text:list-item>
   </text:list>
   <text:p text:style-name="Standard">Indent (Backspace)</text:p>
   <text:list xml:id="list1087656376" text:continue-numbering="true" text:style-name="WWNum1">
    <text:list-item>
     <text:p text:style-name="P2">Test1</text:p>
    </text:list-item>
   </text:list>

Differences are:
1. When Indent with Shift+Enter there is 1 paragraph <text:p>...</text:p> with line breaks
   When Indent with Backspace there are 3 paragraphs no line breaks
2. In Indent-Bug2.fodt paragraphs with "Indent (Backspace)" are outside list <text:list>...<text:list>
Comment 8 Cor Nouws 2013-03-02 22:52:43 UTC
Created attachment 75805 [details]
docx file to test what Word creates

Word does the same when hitting backspace the first time, at the start of an empty line with bullet. But different the next time you hit backspace there.

I attach a docx with the test, and in a moment the same, saved as ODT in WOrd2010
Comment 9 Cor Nouws 2013-03-02 22:53:25 UTC
Created attachment 75806 [details]
same file, saved as .odt in Word2012
Comment 10 QA Administrators 2015-02-19 15:42:25 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2015-03-07 15:03:14 UTC
Reproduced with attachment 75564 [details].

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 12 tommy27 2016-04-16 07:24:58 UTC Comment hidden (obsolete)
Comment 13 QA Administrators 2017-05-22 13:26:17 UTC Comment hidden (obsolete)
Comment 14 Thomas Lendo 2018-11-04 00:52:09 UTC
Can't reproduce with Version: 6.2.0.0.alpha1+
Build ID: 612a107464c1889fdc4806a3c86da8c2fbf452c8
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: threaded

I'll close as RESOLVED WORKSFORME.