Bug 61576 - fontwork trailing space
Summary: fontwork trailing space
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: FontWork-WordArt
  Show dependency treegraph
 
Reported: 2013-02-27 20:14 UTC by Scott
Modified: 2021-10-13 19:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott 2013-02-27 20:14:49 UTC
This is minor, just a nuisance

Problem description: 
When adding a new Fontwork, you must always delete the trailing space at the end before formatting the text or it won't take.

Steps to reproduce:
1. Got to the Fontwork gallery and choose a Fontwork.
2. Double click the new Fontwork to edit the text.
3. Double click to select the text and choose a new font, click off of Fontwork.
4. Fontwork does not change font.

Current behavior:
1. Got to the Fontwork gallery and choose a Fontwork
2. Double click the new Fontwork to edit the text
3. Select the text and press the end key, which will put you after a single trailing space after the text.
4. Backspace out the space.
5. Select text and format.

Expected behavior:
1. Got to the Fontwork gallery and choose a Fontwork.
2. Double click the new Fontwork to edit the text.
3. Double click to select the text and choose a new font, click off of Fontwork.
4. Fontwork now displays new font look.
              
Operating System: Windows 7 x86
LO Version: 4.0.0.3
Comment 1 Brenda Granados 2013-03-01 17:53:25 UTC
Hi, I have confirmed that this is an issue on 4.1.0.0alpha0+ using Windows 8. If you don't delete the extra space at the end, the text appears to change to the new font, but the fontwork does not. I have confirmed that deleting the space at the end of the text, and then changing the font and clicking off the fontwork gives the desired result that the fontwork is changed.

I am lowering the priority to minor, medium. I agree it's a nuisance, too, but the workaround gets the job done for now. I hope you agree.

Version: 4.1.0.0alpha0+ (Build ID: cad65120c6da901bf9fe33ab16ad22217efed0c)
Platform: Windows 8 x64

Thank you for reporting this bug!

LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link: https://wiki.documentfoundation.org/QA/BugTriage  There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists
Comment 2 Scott 2013-03-01 18:06:28 UTC
I would agree. Thanks for your effort.
Comment 3 A (Andy) 2015-02-14 22:18:04 UTC
Reproducible with LO 4.4.0.3, Win 8.1:

The Fontwork is only changed if the space at the end is also selected, afterwards this space can be deleted with the backspace key.  

Note: The formatting toolbar is not shown after the Fontwork is selected and has to be made available manually with VIEW -> TOOLBARS -> FORMATTING.
Comment 4 QA Administrators 2016-02-21 08:35:05 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-03-06 15:08:28 UTC Comment hidden (obsolete)
Comment 6 Scott 2017-03-16 16:00:45 UTC
Bug Still exists.

Version: 5.3.1.2 (x64)
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US); Calc: group
Comment 7 QA Administrators 2018-05-06 02:30:31 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2020-05-06 03:44:16 UTC Comment hidden (obsolete)
Comment 9 Regina Henschel 2021-10-13 19:32:39 UTC
I cannot reproduce it. Tested with Version: 7.1.5.2 (x64) / LibreOffice Community
Build ID: 85f04e9f809797b8199d13c421bd8a2b025d52b5
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_US); UI: en-US
Calc: threaded

Beside that, the new shapes in the Fontwork Gallery do not have a trailing space in the text.