Download it now!
Bug 61598 - Application crashes after making second page style
Summary: Application crashes after making second page style
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.2.8
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-28 09:28 UTC by Fabrizio Marcotulli
Modified: 2015-02-11 14:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the application hanging (53.99 KB, image/png)
2013-02-28 09:28 UTC, Fabrizio Marcotulli
Details
reproduced on version 4.0.1.2 (84.33 KB, image/png)
2013-03-17 00:59 UTC, Fabrizio Marcotulli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabrizio Marcotulli 2013-02-28 09:28:19 UTC
Created attachment 75672 [details]
Screenshot of the application hanging

I tried making two page styles. The two page styles are largely the same: the Next style is set as the same page style, 1 inch margins, headers and footers on, but different on the first page. the only exception (besides the name of the page style) is that one of the page styles is set to landscape and the other isn't.

I started with the vertical page style, when I was done editing the page style I click apply and then ok.

I do the same thing with the horizontal page style, but this time clicking on "Apply" the page style window hangs and it's title show a "(Not Responding)" message.

I can do this from a blank writer document consistently. I have also had the application crash and send me to the document recovery screen.
Comment 1 Jorendc 2013-03-01 19:48:22 UTC
Thanks for reporting!

@Bug reporter: it's very helpful for us to use a step-by-step guide how to reproduce this bug from scratch (see my example):

I can confirm a crash using following steps:

* Open writer
* Open 'Styles and Formatting' (F11)
* Select 'Page Styles' at the top of that dialog
* Select 'Custom Styles' at the bottom selector

* Right click somewhere in the dialog window > New
* Name = horizontal (for example)
* Next style = horizontal
* go to 'Page'-tab
* Set orientation to Landscape
* go to 'Footer'-tab
* check 'footer on'
* uncheck 'same content on first page'
* click Apply

Result: crash

Tested using Linux Mint 14 x64 and LibreOffice 4.0.1.2 rc
Comment 2 Jorendc 2013-03-01 19:50:45 UTC
Can't reproduce using LibreOffice Version 4.1.0.0.alpha0+ (Build ID: ec583253c3d761847c93a77fa10c065fc334fab) (build today)
Comment 3 Fabrizio Marcotulli 2013-03-17 00:59:54 UTC
Created attachment 76633 [details]
reproduced on  version 4.0.1.2

 specifically version 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985)
Comment 4 Fabrizio Marcotulli 2013-03-17 01:13:24 UTC
Sorry, I forgot to write what I did to reproduce the bug. So here it goes.

* Open writer.
* Press f11 to open the styles and formatting window
* select the Page Styles button on the styles and formatting window
* right click on the blank space of the styles and formatting window and select the "New" option
* Name the page style "Vertical"
* Press TAB to set the next style as vertical
* Go to the Page tab and set the all margins to 1 inch.
* Go to the header tab, check the footer on and uncheck the "same content on first page" checkboxes
* Go to the foother tab and do the same thing.
* Click on the "Apply" button
* Click on the "Ok" button

* right click on the blank space of the styles and formatting window and select the "New" option
* Name the page style "Horizontal"
* Press TAB to set the next style as Horizontal
* Go to the Page tab and set the page to landscape all margins to 1 inch.
* Go to the header tab, check the footer on and uncheck the "same content on first page" checkboxes
* Go to the foother tab and do the same thing.
* Click on the "Apply" button
* Click on the "Ok" button
* Click anywhere on the page

After this last step the application starts "thinking" and hangs.

I'll try to upload a youtube video if further clarification is requested.
Comment 5 Jean-Baptiste Faure 2013-05-04 08:31:06 UTC
Reproducible with LO 4.0.4.0+ (Build ID: 924fdc8773a75de54b6ca6ceeaa686035b1f270) under Ubuntu 12.04 x86-64
The crash comes from the Apply button when you push it for the second page style you defined.

Same problem for me with Version: 4.1.0.0.alpha0+ (Build ID: a80ae494533f3be2009d623478ff57e16bcc8be)

Best regards. JBF
Comment 6 Caolán McNamara 2015-02-11 14:36:12 UTC
confirmed in 4.1, but fixed in last 4.2