Download it now!
Bug 61620 - TABLE: Formatting lost when editing numeric field
Summary: TABLE: Formatting lost when editing numeric field
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-28 15:13 UTC by john.hendrikx
Modified: 2015-02-27 22:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john.hendrikx 2013-02-28 15:13:10 UTC
Writer keeps removing formatting in table cells after editing them and reverts it to default (Text @).  Writer will also set the language to Default UK, no matter what the document language.

1) Create a new document.
2) Inserts a table.
3) Type a number in a format that is not your default locale, for example "77,55".
4) Change Number Format of this cell to Language Dutch (Netherlands) and the format to "0,00".
5) Edit the cell and change the value to "77,5" by just deleting the last 5 and then pressing Tab to exit the cell.
6) Check Number Format again and notice the format was lost.

Number recognition is globally off for Tables.  Number recognition is off for this specific table.  After EVERY edit the Number Format is lost.

This bug has been present for years, but it finally irked me enough to report it.  Also see this post by a user with the same problem (especially the last XML part): http://en.libreofficeforum.org/node/4503

The problem is partially mitigated by changing the default locale to Dutch (where it is UK normally) but Writer STILL changes the Number Format to '@'.  

Please resolve this.
Comment 1 Joel Madero 2013-02-28 16:52:25 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 3.6.4.3 
Platform: Bodhi Linux 2.2 x64
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Minor (annoying but doesn't prevent high quality work, just requires an extra step to reset the formatting)
Medium (default is low, but I think this one is annoying enough to qualify for medium)


As for the steps, I can reproduce much easier:

1) Startup Writer, insert table
2) Make 1x1 table
3) Type 1.505
4) Highlight and set number format to Number (with 3 decimal places)
5) Click ok
6) Click in cell and delete the last 5, click out of cell
7) Go back into number format for cell

Observed: You see it switched back to "text"

Expected: Should remain as number

As for the UK issue - I'm not seeing this and maybe needs to be reported as a separate issue.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage
Also, good bug reports help tremendously in making the process go smoother, please visit WIKI to see examples of great bug reports..
Lastly, if you don't have time to donate, please consider monetary donation to our great non profit by looking here: http://donate.libreoffice.org/ so we can continue to provide the infrastructure, support, bug fixes, etc... that we all enjoy so much. Remember even $5 goes a long way :)
Comment 2 QA Administrators 2015-02-19 15:40:47 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 3 Jean-Baptiste Faure 2015-02-27 22:40:17 UTC
I do not reproduce the problem with LibreOffice 4.2.2.0.0+ built at home under Ubuntu 14.10 x86-64.

Closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF