Bug Hunting Session
Bug 61710 - UI IMPRESS: in transition Diagonal Squares, direction From left to ... is To Left, and From Right is To Right
Summary: UI IMPRESS: in transition Diagonal Squares, direction From left to ... is To ...
Status: RESOLVED DUPLICATE of bug 48551
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: difficultyBeginner, filter:ppt, filter:pptx, needsDevEval, skillCpp
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2013-03-02 18:33 UTC by gmolleda
Modified: 2019-09-24 07:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
ODP (12.00 KB, application/vnd.oasis.opendocument.presentation)
2013-03-03 15:59 UTC, Florian Reisinger
Details
PPTX (17.81 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-03-03 15:59 UTC, Florian Reisinger
Details
PPT (73.50 KB, application/vnd.ms-powerpoint)
2013-03-03 16:04 UTC, Florian Reisinger
Details
PPTX with LibO 3.3.4 (6.06 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-03-03 16:06 UTC, Florian Reisinger
Details
Bug withouth import. Only odp. (16.33 KB, application/vnd.oasis.opendocument.presentation)
2019-09-24 06:09 UTC, gmolleda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gmolleda 2013-03-02 18:33:53 UTC
When you use the effect "Diagonal Squares", if you choice Direction "From left to bottom" then the direction realy is from right to bottom.

The source code is correct because if you save in ppt format and open with MS Powerpoint then the direction is "To left..." or "To right..." correctly.

The problem is that in MS Office the direction is "TO ..." but in LibreOffice is "FROM ...".

Anybody could change left and right in directions of effect "Diagonal Squares"?

Thanks.
Comment 1 Florian Reisinger 2013-03-03 15:59:19 UTC
Hi tested with LibO 4.0 and MS powerpoint 2010...

Reproduce: Compare TO-left.pptx (for PPT) down and TO-left.ods (for LibO because of a bug...)

PPT: Left bottom to right upper corner
LibO: Invers...
Comment 2 Florian Reisinger 2013-03-03 15:59:42 UTC
Created attachment 75842 [details]
ODP
Comment 3 Florian Reisinger 2013-03-03 15:59:58 UTC
Created attachment 75843 [details]
PPTX
Comment 4 Florian Reisinger 2013-03-03 16:04:17 UTC
Created attachment 75844 [details]
PPT

Working with PPT and LibO 4
Comment 5 Florian Reisinger 2013-03-03 16:06:34 UTC
Created attachment 75845 [details]
PPTX with LibO 3.3.4
Comment 6 Florian Reisinger 2013-03-03 16:08:14 UTC
Setting version to oldest confirmed version. Sorry for the number of mails...
Comment 7 Jorendc 2013-03-03 16:21:11 UTC
Marking as ProposedEasyHack
Comment 8 gmolleda 2013-03-03 16:49:26 UTC
Attention: the error NOT IN CPP source. The error is only in TEXT NAME of direction effect.
Comment 9 gmolleda 2013-03-03 16:51:56 UTC
The FILE IMPORT function is correct.

The incorrect is text because if you create a new presentation, and use the effect, and choice direction From left... the direction is really from right.
Comment 10 Jorendc 2013-03-03 16:59:47 UTC
(In reply to comment #9)
> The FILE IMPORT function is correct.

Yes
 
> The incorrect is text because if you create a new presentation, and use the
> effect, and choice direction From left... the direction is really from right.

I'm not a developer, but I think we can do 2 changes

1) or we can change EVERYTHING to it's inverse. In the C++ code it is also "FADE_FROM_UPPERRIGHT" for example. (http://opengrok.libreoffice.org/search?q=%22diagonal-squares-left-down%22&project=core). I don't know what the effect is on existing presentations when we change that + this change is big.

2) we just invert the ppt(x) export function "FADE_FROM_UPPERRIGHT" must me interpret as "FADE_FROM_LEFTDOWN" or something like that (need to be examined how it is exported). This way only the ppt export is affected.
Comment 11 Jorendc 2013-03-04 14:04:12 UTC
@gmollleda: please do not change the versionnumber. This should be the oldest version of libreoffice we can reproduce the behavior. Thanks
Comment 12 gmolleda 2013-03-04 14:09:23 UTC
In version 4.0.1.2 rc still bad.

But looking backwards compatibility.
Comment 13 Joel Madero 2014-02-27 23:15:54 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 14 Robinson Tryon (qubit) 2015-12-14 06:12:07 UTC Comment hidden (obsolete)
Comment 15 gmolleda 2016-03-20 08:07:02 UTC
Is this error the same that #48551 ?
https://bugs.documentfoundation.org/show_bug.cgi?id=48551

If it is correct, this bug is duplicate of 48551.

A ver cuando se usa el esperanto como idioma internacional que el inglés (como el español o cualquier otro irregular) es discriminatorio por nacionalidad y renta (mucho dinero y tiempo invertidos para aprenderlos).
Comment 16 QA Administrators 2017-05-22 13:20:03 UTC Comment hidden (obsolete)
Comment 17 gmolleda 2017-05-22 18:20:52 UTC
Same bug in version 5.3.3.2
Comment 18 QA Administrators 2018-05-23 02:36:27 UTC Comment hidden (obsolete)
Comment 19 gmolleda 2018-05-23 09:43:44 UTC
Same behaviour in LibreOffice 6.0.4.2 Impress.
Comment 20 Roman Kuznetsov 2018-12-03 17:15:55 UTC
in 

Version: 6.3.0.0.alpha0+
Build ID: 878c36f829fd88cda95ca218a2cf03003f50e53d
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-11-24_22:47:49
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

there isn't any animation when I open PPTX from attach in LO
Comment 21 Buovjaga 2019-09-23 14:56:55 UTC
Regarding PPTX, I don't really understand the info in this report, because even old versions (3.5.0, 4.4.7) do not display any transition at all for the slide. This is also when opening the ODP, saving as PPTX and reloading.
Comment 22 gmolleda 2019-09-24 06:09:55 UTC
Created attachment 154399 [details]
Bug withouth import. Only odp.

Yes, you are right. I realized when importing ppt into libreoffice but simply creating a text with animated diagonal squares you can see. Attached new example.

Jes, vi pravas. Mi rimarkis, kiam mi importis ppt en libreoffice, sed mi nun simple kreas tekston kun movbildo: diagonalaj kadroj, kiujn vi povas vidi. Mi kunligas novan ekzemplon.
Comment 23 gmolleda 2019-09-24 07:00:58 UTC
This is a duplicate bug of #48551(In reply to gmolleda from comment #15)
> Is this error the same that #48551 ?
> https://bugs.documentfoundation.org/show_bug.cgi?id=48551
> 
> If it is correct, this bug is duplicate of 48551.
> 
> A ver cuando se usa el esperanto como idioma internacional que el inglés
> (como el español o cualquier otro irregular) es discriminatorio por
> nacionalidad y renta (mucho dinero y tiempo invertidos para aprenderlos).

Yes. It is duplicate of #48551.

*** This bug has been marked as a duplicate of bug 48551 ***