Bug Hunting Session
Bug 61744 - Table Cells Overlap in Writer View
Summary: Table Cells Overlap in Writer View
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-03 16:21 UTC by John Perez
Modified: 2015-03-01 09:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots of the tables (477.44 KB, application/x-gzip)
2013-03-03 16:30 UTC, John Perez
Details
The file where the problem is encountered. Search for "clomiphene citrate" under Birth Control to go to the area of interest. (268.15 KB, application/vnd.oasis.opendocument.text)
2013-03-03 21:37 UTC, John Perez
Details
Screenshot with print layout view (140.55 KB, image/png)
2013-03-04 00:07 UTC, m.a.riosv
Details
I can reproduce it sometimes ... Linux Mint 14 x64 (130.05 KB, image/png)
2013-03-04 17:53 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Perez 2013-03-03 16:21:15 UTC
I am currently working on a large table, but there is a specific section of the table where the cells and text overlap. This renders the text of the concerned sections unreadable.

The bug seems to be isolated in one part of the table and only exists in Print Layout. It disappears in Web Layout. Since printing relies on Print Layout, the problem is also printed out.

Furthermore, when switching from Web Layout to Print Layout, the cells are correct for a few seconds then Writer stops responding. When it returns, the cells overlap.

Some attempts at fixing were made like deleting/inserting cells but to no avail.

Steps to reproduce:
-None specifically as it seems to be how large tables are treated.

Current behavior:
Cells overlap in writer view, but corrects in web view.

Expected behavior:
Cell formatting should be correct in writer view.
Comment 1 John Perez 2013-03-03 16:30:07 UTC
Created attachment 75848 [details]
Screenshots of the tables
Comment 2 Joel Madero 2013-03-03 17:27:08 UTC
Marking this as NEEDINFO.

We'll need more than just this description to attempt to reproduce and/or see the issue.

Please attach the large document, if it's too large, if possible send it to my email address and I'll personally check it. 

Once you get me the document, open this as UCNONFIRMED and I'll try to triage the issue asap.
Comment 3 John Perez 2013-03-03 21:37:07 UTC
Created attachment 75859 [details]
The file where the problem is encountered. Search for "clomiphene citrate" under Birth Control to go to the area of interest.
Comment 4 m.a.riosv 2013-03-04 00:07:44 UTC
Created attachment 75875 [details]
Screenshot with print layout view

I can not reproduce with:
Win7x64 Ultimate
Version 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985)
Comment 5 Joel Madero 2013-03-04 05:03:24 UTC
Version: 4.0.0.3 release
Bodhi Linux x64

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

This looks fine to me as well, because of this I suspect it's an environment issue.

@John - please reset your user profile to see if that fixes it https://wiki.documentfoundation.org/UserProfile

Marking as WFM as we have two QA staff unable to reproduce with a test file that is having a problem on a single machine

cc'ing Joren to get one last opinion

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps and relevant attachments.
Comment 6 John Perez 2013-03-04 13:24:25 UTC
Thanks for your input, Joel and Mario!

Joel, I did as you advised. Unfortunately, it still persisted, albeit more sporadically now than consistently. Tried it in 4.0.1.2 and still no go. If it's anything, the problem persists on 2 machines. I have a desktop and a laptop (both Ubuntu 12.04.2 x86_64 running LO 4.0.0.3) and the story is the same.

Whatever it is that's on my system, I hope it sorts itself out. Thanks for your time!
Comment 7 Jorendc 2013-03-04 17:52:39 UTC
I can confirm this behavior using Linux Mint 14 x64 and LibreOffice 4.0.1.2 rc.

When I open the document, and scroll to page 54 where that table "Birth Control" (see screenshots) is placed, it looks good.  When I open Page Preview (File > Page Preview or Ctrl + Shift + O) it still looks OK. But, when I "Close Preview" it is all messed up. Suddenly that "Birth Control" section starts at page 52.

I tried to reproduce this multiple times, but can't reproduce this every single time.

What I tried:

* Open that document
* Open the search box (Edit > Find ... or Ctrl+F)
* Type "birth" (without quotes) in the search box
* Click on down arrow once (or hit 'Enter' once)
* Now, click 2 times on arrow up (because that table sections is at the end of the document)
* (select Yes on the dialog if he said that he reached the end of the document)
* Now open Page Preview (File Page Preview or Ctrl + Shift + O or icon on menu bar)
* Close Preview

As I said: this isn't reproducible every time. If it isn't reproducible, please reopen the document without closing LibreOffice. If it's still not reproducible, close LibreOffice and restart it. Try again. I can't find any consistency.

Very odd ... 

Kind regards,
Joren
Comment 8 Jorendc 2013-03-04 17:53:07 UTC
Created attachment 75908 [details]
I can reproduce it sometimes ... Linux Mint 14 x64
Comment 9 Joel Madero 2013-03-04 17:58:46 UTC
Joren - looks like NEW is the right status then, inconsistent bugs are the worst :-/

Normal - prevents high quality work

Medium - default for normal bugs, I think that this is good for now, if this is a regression let's push it to high and try to bibisect it.

@John - can you confirm that this is a regression?
Comment 10 John Perez 2013-03-05 09:31:35 UTC
Joren, yes I can confirm the same behavior using your method. This is what I did:

From an empty desktop:
1. Open the file
2. Search for "clomiphene citrate." At this point, the table is CORRECT.
3. Switch views using CTRL + SHIFT + O
4. Click "Close Preview"
5. Search for "clomiphene citrate" again. This time, the table is INCORRECT.

As further testing, I did this:
6. Click Window --> Close Window
7. Then File --> Open Recent Document --> Pharmacology Drug Table.odt
8. Go back to Step #2.

After several tries,
9. Exit LibreOffice
10. Go back to Step #1

And I also get inconsistent results. In my case, around 3/5 times are broken, but it's still sporadic at best. As for my original method of switching to Web Layout to Print Layout, the results are even more inconsistent. Happens about 1/5 times.

Joel, I'm sorry, but I don't know how to confirm a regression. How can I help with that? If we're referring to versions, the behavior is observable using 4.0.0.3, 4.0.2.1 and 4.0.1.1-Ubuntu.
Comment 11 QA Administrators 2015-02-19 15:41:19 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 12 Jean-Baptiste Faure 2015-03-01 09:43:44 UTC
Not reproducible for me with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64.

Closing as WorksForMe. Please, feel free to reopen if you still encounter the same problem with current stable version.

Best regards. JBF