Download it now!
Bug 61766 - FILEOPEN: Text box of particular docx rendered as image with white background
Summary: FILEOPEN: Text box of particular docx rendered as image with white background
Status: RESOLVED DUPLICATE of bug 90720
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-03 22:46 UTC by Jorendc
Modified: 2015-05-02 13:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Docx file (468.22 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-03-03 22:46 UTC, Jorendc
Details
How it should look like (using Word for Mac 2011) (504.14 KB, application/pdf)
2013-03-03 22:47 UTC, Jorendc
Details
How it actually look using LibreOffice Master Mac OSX (397.39 KB, application/pdf)
2013-03-03 22:47 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorendc 2013-03-03 22:46:23 UTC
Created attachment 75868 [details]
Docx file

Steps to reproduce:
1. Open attached docx-file, created using MS Word 2007

Current behavior: text boxes are imported as images, doesn't have a transparant background and overlaps the background image. This result in the fact you can't edit the text anymore.

Mac OSX 10.8.2, LibreOffice 4.0.1.2 and Version 4.1.0.0.alpha0+ (Build ID: 5fcb553c862d407aadb0320925723d3c2f70bfe)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-02-26_22:56:53

PS: I'm not the creator of this file; Someone gave it to me via IRC-chat.
Operating System: All
Version: 4.0.1.2 rc
Comment 1 Jorendc 2013-03-03 22:47:19 UTC
Created attachment 75869 [details]
How it should look like (using Word for Mac 2011)
Comment 2 Jorendc 2013-03-03 22:47:52 UTC
Created attachment 75870 [details]
How it actually look using LibreOffice Master Mac OSX
Comment 3 Joel Madero 2013-03-04 06:25:31 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 3.6.5.2 
Platform: Bodhi Linux 2.2 x64


As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Major - loss of data/formatting
High - default for major bugs, seems appropriate
Comment 4 Jorendc 2013-10-15 18:09:40 UTC
Still reproducible using windows 8

Version: 4.2.0.0.alpha0+
Build ID: 3de7c7b5854335a82948560b3cc5b302171e340f
TinderBox: Windows-x86@47-TDF, Branch:master, Time: 2013-10-15_13:31:21
Comment 5 Jorendc 2015-01-13 20:18:24 UTC
Still reproducible tested using Windows 7 x64 and LibreOffice Version: 4.4.0.2
Build ID: a3603970151a6ae2596acd62b70112f4d376b990
Locale: nl_BE
Comment 6 Jorendc 2015-04-29 18:56:11 UTC
Still repro Version: 5.0.0.0.alpha1+ (x64)
Build ID: 2932d2db599c09ecce3faa2d627e9ee4f251183a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-28_23:53:22
Locale: nl_BE

Kind regards,
Joren
Comment 7 Jorendc 2015-05-02 13:32:06 UTC
White background is now transparant background.

Thanks to http://cgit.freedesktop.org/libreoffice/core/commit/?id=049e84125fb76f7a1a051d7cac2e04e37a7cd190

So marking as a dupe of bug 90720

*** This bug has been marked as a duplicate of bug 90720 ***