Bug Hunting Session
Bug 61788 - EDITING: Impossible to drag&drop text from other applications to LibreOffice
Summary: EDITING: Impossible to drag&drop text from other applications to LibreOffice
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2013-03-04 13:16 UTC by Emir Sarı (away)
Modified: 2015-05-12 08:34 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı (away) 2013-03-04 13:16:45 UTC
Steps to reproduce:

1. Open an application (Firefox, TextEdit, Safari etc.)
2. Select some text
3. Drag the text from application and drag it to any LO component

Expected behaviour:

1. Text should be pasted.

Actual behaviour:

1. Nothing happens 

This is some serious functionality lost, and I hope this gets fixed as soon as possible. I don't know if this is a regression, it would be great if someone could confirm this on 3.6 branch.
Comment 1 Joel Madero 2013-03-04 17:05:39 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 4.1.0.0.alpha0+ (Build ID: 2bb13b83e40aec362964d26921a3fc1660a5da2)
 Date:   Thu Feb 28 20:17:25 2013 +0100 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +

On Linux the behavior is even stranger, if I drag "1. Open an application (Firefox, TextEdit, Safari etc.)" to writer I get this:

<pre class="bz_comment_text" id="comment_text_0"> 1. Open an application </pre>

Same behavior with 3.6.5.2, not marking as anything as I want someone with OS X to test this.

Joren you mind checking this one out?
Comment 2 Jorendc 2013-03-04 19:25:49 UTC
Sounds very related to Bug 44621, except this is a bug regarding text, not images.

(In reply to comment #0)
> Actual behaviour:
> 
> 1. Nothing happens 

I can reproduce this behavior using Mac OSX 10.8.2 with LibreOffice 4.0.1.2

(In reply to comment #1)
> On Linux the behavior is even stranger, if I drag "1. Open an application
> (Firefox, TextEdit, Safari etc.)" to writer I get this:
> 
> <pre class="bz_comment_text" id="comment_text_0"> 1. Open an application
> </pre>

I can reproduce that behavior also using Linux Mint 14 x64 LibreOffice Version 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985).

Therefore I mark this as NEW.

Kind regards,
Joren
Comment 3 V Stuart Foote 2013-05-05 17:41:49 UTC
Dragging selected text from FireFox to Writer
 
WFM Windows 7 sp1, 64-bit
LibreOffice 4.0.3.3, and also 4.1.0 alpha (2013-04-29)

Only affecting OSX and Linux builds?
Comment 4 V Stuart Foote 2013-05-06 05:26:18 UTC
Workikng with LibreOffice 4.0.2.2 on Fedora 18 Linux, 32-bit, GNOME 3 Desktop, and FireFox 20.0

If dragging highlighted text from Firefox I also get the 
<pre class="bz_comment_text" id="comment_text_0">Steps to reproduce: and </pre> tags.  

But I think those tags are a Firefox issue (and perhaps some other apps). Because, when highlighting content in Firefox, a <right> mouse click shows a context menu that includes "View Selection Source" that opens a pop-up frame titled "DOM Source of Selection - Mozilla Firefox"

The tagged Doccument Object Model content of the Source of Selection is exactly what is dropped into Writer when dragged.

In other GNOME 3 desktop applications -- GEdit, Dictionary-- highlighted text can be draged and droped into Writer with no formatting issues.

So could be a non-issue with Linux and actually an OSX only issue.
Comment 5 Alex Thurgood 2015-05-12 08:33:14 UTC
This now works on master daily build OSX, since :

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cfdd89f10fdc15b36bd0d1023e49ca3752feb51e

Thanks to Manik for some great work here !