Download it now!
Bug 61882 - FORMATTING: Enhancement: Make text in arrows/lines better visible
Summary: FORMATTING: Enhancement: Make text in arrows/lines better visible
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-06 01:20 UTC by bugquestcontri
Modified: 2016-05-01 09:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
image how it looks now and how it will look with the new feature (5.40 KB, image/gif)
2013-03-06 01:22 UTC, bugquestcontri
Details
test file (12.54 KB, application/vnd.oasis.opendocument.presentation)
2015-02-28 21:30 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-03-06 01:20:53 UTC
This applies to Impress, Draw, Writer and Calc

Problem description: 
The possibility to add a text in an arrow/line is great. 

However text appears behind the line and looks as "strike through". Depending on text font and line thickness text is very difficult to read. See attachment "standard"

Solution
Make text appearing in front of the arrow. Additional enable a the choice of background colors for the background of the text. See attachment "artificially created"

To the best of my knowledge this feature is not available in MSO, thus a UPS for LibO
Operating System: Windows XP
Version: 3.6.5.2 release
Comment 1 bugquestcontri 2013-03-06 01:22:23 UTC
Created attachment 75994 [details]
image how it looks now and how it will look with the new feature
Comment 2 blubb 2013-03-23 19:36:55 UTC
Confirmed. Impress can't make background colours for texts, which would be a solution for that problem. Another solution would be to move the text above the arrow (Format -> Text -> Text -> change the bottom space to the border to get the text above the arrow).
Comment 3 bugquestcontri 2013-03-24 10:29:13 UTC
@blubb - Thanks for looking into this bub. 
Moving text above (or below) an arrow would - from my point of view - only an additional but not an alternative solution. As an additional solution it could be a nice feature.
Comment 4 QA Administrators 2015-02-19 15:46:50 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 5 bugquestcontri 2015-02-25 17:04:44 UTC
To me the comment of the QA administrator is not acceptable. The enhancement is not yet to be seen in 4.3.6. Thus why are enhancement request filed if they will get closed the way it is done here.

I am of the impression that someone just closed bug reports/enhancement requests to reduce the number of open issues.

I would happily accept a statement. like enhancement will published in version 4.x.. I also can live with a statement like "for technical reasons this is not possible.
Comment 6 Jean-Baptiste Faure 2015-02-28 21:29:08 UTC
Nobody said to close this enhancement. The request is: please test again with current stable version and say us if the reported issue is still there.

That said, the text appears in front of the arrow; it is clear if you give the text a color different from the arrow color.
You can too move the text above the arrow: click on the text and apply Align Bottom in the sidebar. If you insert a second paragraph with a small font size you can define the distance between the text and the arrow (play with the spacing below the paragraph).

The only thing missing for me is that you can't define a background color for the paragraph.

Best regards. JBF
Comment 7 Jean-Baptiste Faure 2015-02-28 21:30:35 UTC
Created attachment 113784 [details]
test file
Comment 8 bugquestcontri 2015-03-01 06:41:06 UTC
@ Jean-Baptistem explanation is accepted. The pre-formulated text of the QA gave me the impression I wrote about.

I used the portable version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: en_US

Result is the same. By default text appear on front (or behind) the arrow. Not yet a background appearing.to make the text normally to read. Only shifting the text position above or below the line is possible. You also showed this in your example.
Comment 9 tommy27 2016-04-16 07:23:40 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 10 Jean-Baptiste Faure 2016-05-01 09:19:47 UTC
In LO 5.1 you can add highlighting on characters. It acts as background so I consider that this enhancement request is fulfilled.

Closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF