Bug Hunting Session
Bug 61916 - Font Preview Foreground always black even if background also Black
Summary: Font Preview Foreground always black even if background also Black
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-06 19:20 UTC by Andreas B.
Modified: 2016-05-01 09:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
See "Preview" in "Character" Dialog (91.92 KB, image/png)
2013-03-06 19:20 UTC, Andreas B.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas B. 2013-03-06 19:20:12 UTC
Created attachment 76041 [details]
See "Preview" in "Character" Dialog

Steps to reproduce (minimal version):

- Start Writer
- Write some text
- Mark Text and set background to black => foreground will automatically be set to white
- Mark Text, right click and select "Character"
- Text preview is black font on black background, also not really visible.

The foreground should not be black, it should also be automatically white.
Comment 1 Andreas B. 2013-03-06 19:22:39 UTC
The Atachment mime is wrong detected, it's not "text/plain" it should be "image/png".

Use save as and then open the image...
Comment 2 Adolfo Jayme 2013-03-06 19:57:48 UTC
Comment on attachment 76041 [details]
See "Preview" in "Character" Dialog

Fixed the mimetype for you.
Comment 3 crazyskeggy 2013-03-06 20:18:31 UTC
Reproducible in 4.0.0.3 on Windows XP.
Comment 4 QA Administrators 2015-02-19 15:49:41 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 5 Jean-Baptiste Faure 2015-02-28 22:11:16 UTC
Still there in LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64.

Best regards. JBF
Comment 6 tommy27 2016-04-16 07:27:31 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 7 Jean-Baptiste Faure 2016-05-01 09:29:30 UTC
Not reproducible for me anymore with LO 5.1.4.0.0+ and current master with the default GTK3 plugin.

Closing as WorksForMe. Feel free to reopen if you disagree.

Best regards. JBF