Download it now!
Bug 61956 - FORMATTING: Clear Direct Formatting corrupting formatting in a document
Summary: FORMATTING: Clear Direct Formatting corrupting formatting in a document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.1 rc
Hardware: Other Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-07 10:08 UTC by calvin509
Modified: 2015-10-14 20:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Attached is an excerpt of the corrupted document where the bug occurs (30.01 KB, application/vnd.oasis.opendocument.text)
2013-03-07 10:08 UTC, calvin509
Details

Note You need to log in before you can comment on or make changes to this bug.
Description calvin509 2013-03-07 10:08:40 UTC
Created attachment 76103 [details]
Attached is an excerpt of the corrupted document where the bug occurs

In a quite long document, whenever I try to use Clear Direct Formatting, random portions of the text (up to entire paragraphs) switch to superscript, while other portions remains in normal position. 
Manually setting character position to normal obviously gets erased when clearing direct formatting.
Changing all the text to the Default style does not resolve this bug.
Copy-pasting the text to another document does not resolve it either.


I believe the normal behaviour of Clear Direct Formatting should be to change all the text back to unformatted text, normal position.

I attach an excerpt of my document to reproduce the bug.

Is there a generic way to repair such a corrupted formatting in a document ?
Operating System: Linux (Other)
Version: 4.0.1.1 rc
Comment 1 Joel Madero 2013-03-07 17:31:59 UTC
Can you provide reproducible steps from a clean document? This way we can confirm the bug and track down the cause.

With the document attached, where is the problem? Can I do "Clear Direct Formatting" and see a specific issue?

As for the last question, best to ask on our ask site or on the mailing list as you'll get a lot more feedback - as far as I know the answer is no.

Marking as NEEDINFO until reproducible steps are provided. Once you provide the steps please mark as UNCONFIRMED and we'll take a look at it
Comment 2 calvin509 2013-03-12 16:05:13 UTC
Sorry, but apart "working a long time on a long document" and maybe "editing and saving back and forth in LibreOffice and MS Office", I don't have any more specific reproducible step from a blank document.

In the attached document, the reproducible step is the following : doing "Clear Direct Formatting" will do nothing, thus failing to restore the normal position for the text of two paragraphs.


(In reply to comment #1)
> Can you provide reproducible steps from a clean document? This way we can
> confirm the bug and track down the cause.
> 
> With the document attached, where is the problem? Can I do "Clear Direct
> Formatting" and see a specific issue?
> 
> As for the last question, best to ask on our ask site or on the mailing list
> as you'll get a lot more feedback - as far as I know the answer is no.
> 
> Marking as NEEDINFO until reproducible steps are provided. Once you provide
> the steps please mark as UNCONFIRMED and we'll take a look at it
Comment 3 Marc Kaulisch 2013-04-15 20:00:41 UTC
I can confirm the wired behaviour with the attached document under Windows 8 (64bit), LibreOffice 4.0.2.2.

I changed the standard style to Garamond font. The second paragraph (starting with "A nouveau" is not changing its format when clear formatting is pressed although standard paragraph style is selected and applied to it before.
Comment 4 Marc Kaulisch 2013-04-15 20:09:48 UTC
Some more information on this bug - I confirm as new ;-)
If I copy the text into a new document. I can see that this bug only happens with the standard style (Textkörper in German). With the citation style the clear formatting works.

1. I apply the citation style to the paragraph.
2. I change the style setting,
3. the format change is applied to the paragraph (as expected) 
4. I change the font size of this paragraph 
5. I apply clear formatting - the paragraph style is back.

Be honest I had the same problem already with one of my documents but thought it is something I do wrong.
Comment 5 Fiable.biz 2014-09-26 10:54:34 UTC
This might be the same bug as bug #47471.
Comment 6 QA Administrators 2015-10-14 19:56:54 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.1 or preferably 5.0.2.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-10-14
Comment 7 Marc Kaulisch 2015-10-14 20:23:32 UTC
I tested it now again with 5.0.3.1 64bit on Windows 10 (64bit).

It looks like Clear Formatting works as expected for the characters.

One caveat: If the paragraph is not in the format of its style then I do not get the format of the style - although I would expect this behaviour. I have to re-apply the paragraph style...