Download it now!
Bug 62098 - RTL EDITING: Strange table width on resizing cells or pasting a table included vertical text flow
Summary: RTL EDITING: Strange table width on resizing cells or pasting a table include...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2013-03-10 11:37 UTC by Muhammad Bashir Al-Noimi
Modified: 2017-11-03 16:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
How the table appears in case of copy and pasting it or even resize it (19.55 KB, image/png)
2013-03-10 11:37 UTC, Muhammad Bashir Al-Noimi
Details
The original file of the screenshot (12.75 KB, application/vnd.oasis.opendocument.text)
2013-03-10 11:39 UTC, Muhammad Bashir Al-Noimi
Details
another testdoc (9.37 KB, application/vnd.oasis.opendocument.text)
2013-04-17 06:20 UTC, Lior Kaplan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Muhammad Bashir Al-Noimi 2013-03-10 11:37:57 UTC
Created attachment 76266 [details]
How the table appears in case of copy and pasting it or even resize it

Any table has vertical text flow appears ugly in any cell appears incorrectly in case of pasting it or resizing any cell as shown in the screenshot. While it works fine in case modifying it into LTR mode.
Comment 1 Muhammad Bashir Al-Noimi 2013-03-10 11:39:30 UTC
Created attachment 76267 [details]
The original file of the screenshot
Comment 2 Faisal Menawer 2013-03-11 07:17:13 UTC
thank you for the report

Reproduced in LibreOffice 4.0.1.2 
on ubuntu 12.10 64-bit

step to reproduced:
1-open writer.
2-change the page direction to RTL(Right To Left).  
3-insert table.
4-change one of the cell to vertical.
5-copy the table then paste it.
Comment 3 Lior Kaplan 2013-04-17 06:13:56 UTC
Comment on attachment 76267 [details]
The original file of the screenshot

I've fixed both attachments mimetypes, please notice that in the future...
Comment 4 Lior Kaplan 2013-04-17 06:20:06 UTC
Created attachment 78123 [details]
another testdoc
Comment 5 QA Administrators 2015-03-04 02:22:12 UTC Comment hidden (obsolete)
Comment 6 Lior Kaplan 2015-03-12 18:48:15 UTC
Still happens on 4.3.3.2 (Debian testing 64bit)
Comment 7 tommy27 2016-04-16 07:25:21 UTC Comment hidden (obsolete)
Comment 8 Omer Zak 2017-11-03 02:51:47 UTC
Works for me at:

Version: 5.4.2.2.0+
Build ID: 1:5.4.2-3~bpo9+1
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.utf8); Calc: group

OS: Debian 64bit Stretch (Debian 9.2, with some backported packages)
Comment 9 Eyal Rozenberg 2017-11-03 16:20:30 UTC
I don't understand what the instructions are for reproducing the bug now..