Download it now!
Bug 62120 - VIEWING: graphic file wmf are display incorrect
Summary: VIEWING: graphic file wmf are display incorrect
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-10 19:33 UTC by Manfred Haider
Modified: 2016-09-03 11:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
original wmf file (170.70 KB, image/x-wmf)
2013-03-10 19:41 UTC, Manfred Haider
Details
file selector box for including graphics from file (50.90 KB, image/png)
2013-03-10 19:44 UTC, Manfred Haider
Details
incorrect display of an wmf graphic file (12.03 KB, image/png)
2013-03-10 19:46 UTC, Manfred Haider
Details
original wmf piucture (129.13 KB, image/png)
2013-09-10 15:15 UTC, John Bakker
Details
wmf file incorrect display in odt document (330.63 KB, application/pdf)
2013-09-10 15:17 UTC, John Bakker
Details
Comparison of display of original WMF open with LO 5.2.1.2 and inserted into MS Word 2013 (173.06 KB, image/png)
2016-09-03 11:30 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manfred Haider 2013-03-10 19:33:38 UTC
Problem description: incorrect display of wmf files

Steps to reproduce:
1. inlude / graphics / from file
2. look: there is no preview for wmf files, but for all other types of file
3. ....

Current behavior: incorrect (poor) display

Expected behavior: correct display

I got some information, that an import filter has been modified.
The last version, that dealed correct with wmf files is OpenOffice 3.2. Beginning with OO 3.3, and all LibreOffice 
wmf graphics are displayed incorrect.
After sending this report, I will return to OO3.2 on all computers. There is also need to return to Java 6, because some base function do not work otherwise. So, you see, it's a bad situation for me.
I hope for a solution and I hope to be informed about. If I can support you in this matter - don't hasitate to write me: manfred.haider@gmx.de

Best regrads from Bavaria,

Manfred

              
Operating System: Windows 7
Version: 4.0.0.3 release
Comment 1 Manfred Haider 2013-03-10 19:41:32 UTC
Created attachment 76288 [details]
original wmf file

this is the original file to be included
screenShots, how libreOffice writer deals with it will be added separatly
Comment 2 Manfred Haider 2013-03-10 19:44:14 UTC
Created attachment 76289 [details]
file selector box for including graphics from file

here you can see, there is a correct preview for png files but no preview for wmf files
Comment 3 Manfred Haider 2013-03-10 19:46:51 UTC
Created attachment 76290 [details]
incorrect display of an wmf graphic file

here you see, how libreOffice writer displays a wmf graphics file
Comment 4 Joel Madero 2013-03-18 16:49:15 UTC
As you've said you first saw this on 3.2 I am updating version. Our version field is used to show oldest version that has the issue, not latest that it has been tested on or can be seen in (we use comments to state these things)
Comment 5 Joel Madero 2013-03-18 16:53:04 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 4.1.0.0.alpha0+ (Build ID: b514f0ce86e85d9be269ddf2e797befbbf3423f)
Date:   Thu Mar 7 21:46:30 2013 +0200 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal (inserting WMF files essentially useless, image just is very badly imported making professional quality work impossible with WMF files)
High (we supposedly support WMF insertion but it's clear that it's very broken, could be argued that it's a lower priority as you can easily change the file format but this shouldn't be required if we support the file format)

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 6 Marcus Nemes 2013-05-16 07:35:55 UTC
I can confirm this for Version 4.0.2.2 (Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3) running under Win7 32bit.

Additional info: some (but not all) missing elements reappear in the PDF export.

As OpenOffice 3.4.0 works fine, the following workaround can be used in Win7:
1) Import the graphic file in OpenOffice Writer
2) Select the picture and copy it to the clipboard
3) Paste from the clipboard to LibreOffice Writer


Regards,
Marcus
Comment 7 John Bakker 2013-09-10 15:15:09 UTC
Created attachment 85570 [details]
original wmf piucture

Screenshot of wmf file
Comment 8 John Bakker 2013-09-10 15:17:24 UTC
Created attachment 85571 [details]
wmf file incorrect display in odt document

on a Windows 7 computer Versie 4.1.1.2
Comment 9 Cor Nouws 2013-09-10 18:49:16 UTC
(In reply to comment #7)
> Screenshot of wmf file

Thanks John. 
Is it possible to attach the wmf file, so that I can do some testing too?
Cor
Comment 10 Marvin 2014-02-10 09:03:02 UTC
Hi I'm having the same trouble including wmf files to a document.

OS: Win 7
LibO: 4.1.0.4
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28

Best Regards

Marvin
Comment 11 QA Administrators 2015-12-20 16:19:14 UTC Comment hidden (obsolete)
Comment 12 Mike Kaganski 2016-09-03 11:30:15 UTC
Created attachment 127133 [details]
Comparison of display of original WMF open with LO 5.2.1.2 and inserted into MS Word 2013

Cannot reproduce with LO 5.2.1.2.
Please review and close as WORKSFORME, as this has been resolved, and specific commit is unknown.
Comment 13 Cor Nouws 2016-09-03 11:53:05 UTC
indeed OK in 5.3 master too. Thanks Mike.