Bug Hunting Session
Bug 62128 - FORMATTING: Allow replacing comma with anything else in number format #,##0
Summary: FORMATTING: Allow replacing comma with anything else in number format #,##0
Status: CLOSED DUPLICATE of bug 46448
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Number-Format
  Show dependency treegraph
 
Reported: 2013-03-10 21:58 UTC by severoraz
Modified: 2017-05-04 16:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description severoraz 2013-03-10 21:58:45 UTC
The SI/ISO 31-0 norm establishes that the thousands separator should be a single space character (UTF-16 0x0020 character). When I try to give a cell this number format, I find it impossible. 

The default format is coded as #,##0. This prints a comma (,) as a thousand separator for thousands as well as for millions and the consecutive number groups. However, if I try use the number format # ##0, only the thousands are separated with a space.

It would be expected that any character used as a replacement for the comma had the same behavior, i.e. separate digits in groups of 3, from the unit onward.

              
Operating System: Ubuntu
Version: 4.0.1.2 release
Comment 1 Joel Madero 2013-04-15 03:14:31 UTC
I agree with your opinion, just a heads up there is a workaround, put this in:

# ### ### ### ### ### ### ###

that should cover any number you're using. 

Marking this as an enhancement request though, it's a valid point.

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 severoraz 2013-04-27 20:54:18 UTC
Thanks for your understanding Joel, I will use your workaround meanwhile!
Comment 3 severoraz 2013-09-03 22:49:56 UTC
I am sorry to report that the workaround doesn't work because all the spaces are included in the number string, regardless if thousands separators are needed at all. That is, for a format string "# ###", the number 1 is represented as " 1".
Comment 4 severoraz 2015-04-16 15:11:17 UTC
I have seen that in bug #51008 a fix has been implemented, and it consists only of setting the correct thousands separator as the locale's (matching language and country) thousands separator.

Although I think one should be able to select a space (as much as a period or a comma) as language separator, regardless of the locale specifications, I request that in the meantime the space character is set as the default language separator for locale es_CR (Spanish in Costa Rica).

For other users interested in this issue, as a workaround you can set your cells' format language to Esperanto, Estonian or Portugal Portuguese, and you will get a space for thousands separator.
Comment 5 Eike Rathke 2017-05-04 16:02:23 UTC
(In reply to wolterh6 from comment #4)
> Although I think one should be able to select a space (as much as a period
> or a comma) as language separator, regardless of the locale specifications,
That's an RFE to be handled for bug 46448, marking this as duplicate.

> I request that in the meantime the space character is set as the default
> language separator for locale es_CR (Spanish in Costa Rica).
It is since bug 91009 was fixed.

> For other users interested in this issue, as a workaround you can set your
> cells' format language to Esperanto, Estonian or Portugal Portuguese, and
> you will get a space for thousands separator.

*** This bug has been marked as a duplicate of bug 46448 ***