Download it now!
Bug 62131 - EDITING: (Enhancement) Add a connector that targets the center of a shape and is drawn behind it
Summary: EDITING: (Enhancement) Add a connector that targets the center of a shape and...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Connectors
  Show dependency treegraph
 
Reported: 2013-03-10 22:05 UTC by severoraz
Modified: 2016-05-03 14:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description severoraz 2013-03-10 22:05:37 UTC
Draw is my preferred application for drawing a mind map, or concept map. However, I find it very awkward to not be able to target a connector line to the center of a shape (and thus behind it, so the connector line doesn't overlap the shape), for two reasons:
1. This is the instinctive way of connecting 2 shapes in a mind map.
2. Moving around shapes without this feature makes connector lines sometimes end up in awkward spaces.

Please consider implementing this!

              
Operating System: Ubuntu
Version: 4.0.1.2 release
Comment 1 Joel Madero 2013-03-20 16:11:32 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version 4.1.0.0.alpha0+ (Build ID: 9a46e5614f5a0e0bdce3c497f81ca529da8fb5c)
Date:   Mon Mar 18 18:59:09 2013 +0100 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
Medium


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Heiko Tietze 2016-05-02 11:56:18 UTC
Looks like there has been X mas meanwhile (sorry for the delay). You can add glue points at any position, draw connectors between them, and "send it to background" via "arrange". Close this ticket as FIXED.
Comment 3 Cor Nouws 2016-05-03 11:50:53 UTC
"Fixed" is used when a specific commit, resolving the issue, is known.