Bug 62222 - FORMATTING: Free flip of shape give only horizontal flip
Summary: FORMATTING: Free flip of shape give only horizontal flip
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-12 11:31 UTC by Laurent BP
Modified: 2015-04-01 20:21 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Comparison of flipping of shape and a curve (71.10 KB, image/png)
2013-03-12 11:31 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2013-03-12 11:31:41 UTC
Created attachment 76392 [details]
Comparison of flipping of shape and a curve

Problem description: 

Steps to reproduce:
1. draw a shape (not a curve)
2. show 'Flip' button in Drawing toolbar
3. select the shape and the button
4. modify flip axis to not vertical position
5. flip shape

Current behavior:
shape is flipped horizontally (except if flip axis is exactly horizontal, then shape is flipped vertically)

Expected behavior:
Flipping with free angle should be the same as with a curve

It is an old bug, already present in OOo 2.4.1.
              
Operating System: Windows 7
Version: 3.3.0 Beta2
Comment 1 Laurent BP 2013-03-12 11:43:32 UTC
Confirmed with LibO 3.6.5.2
Confirmed with LibO 4.0.1.2
Confirmed with Master Version 4.1.0.0.alpha0+ (Build ID: 09fa9ff842544f68f874e5b505b3e797c376715)

Note: With LibO4, Flip button has been moved to 'Mode' toolbar.
Comment 2 Laurent BP 2013-08-20 17:48:51 UTC
The bug is still present with LibO 4.0.4.2, 4.1.0.4.

The bug is NOT present with Version: 4.2.0.0.alpha0+
Build ID: 2f6cbe13e61c44d4bab8192a4708b698d3d9da33

Should the patch be pushed to 4.1 ?
Comment 3 QA Administrators 2015-04-01 14:42:28 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 4 Laurent BP 2015-04-01 20:21:27 UTC
Bug is not present with Version: 4.3.6.2
Build ID: d50a87b2e514536ed401c18000dad4660b6a169e

Set Status as Resolved > Works for me