Download it now!
Bug 62277 - Consecutive and duplicated error messages when save to overwrite a document without permission.
Summary: Consecutive and duplicated error messages when save to overwrite a document w...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.4.6 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-13 08:44 UTC by Yifan Jiang
Modified: 2017-07-24 20:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
how the boxes looks like in sequence. (18.38 KB, image/png)
2013-03-13 08:44 UTC, Yifan Jiang
Details
how the boxes looks like in sequence. (18.26 KB, image/png)
2013-03-13 08:53 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yifan Jiang 2013-03-13 08:44:26 UTC
Created attachment 76455 [details]
how the boxes looks like in sequence.

Platform: All
Build:    LO 4.0

Steps
-----

    1. $ touch ~/foo.odt; chmod 644 ~/foo.odt; sudo chown root:root ~/foo.odt

    2. Launch writer with an ordinary user

    3. Save the document as ~/foo.odt

    4. Confirm by clicking "Yes" button to overwrite the existed file

Problem
-------

    Of course this is not allowed since the foo.odt is owned by root.

    But there will be 3 consecutive error msg boxes popping out one by
    one after confirming to overwrite the existed odt. (snap shots
    attached)

    I guess it makes sense to alarm only once :)

    
    
Extra Info
----------

    * The only problem happens in SLE HA 11 SP3 chart. When trying similar
      steps in chart SLES11 sp3 and SLED11 sp3, it works all fine.
Comment 1 Yifan Jiang 2013-03-13 08:45:52 UTC
> Extra Info
> ----------
> 
>     * The only problem happens in SLE HA 11 SP3 chart. When trying similar
>       steps in chart SLES11 sp3 and SLED11 sp3, it works all fine.

I am sorry please ignore this garbage info, just it was generated from my local bug report "template" :)
Comment 2 Yifan Jiang 2013-03-13 08:53:36 UTC
Created attachment 76457 [details]
how the boxes looks like in sequence.

a correction of the original one.
Comment 3 Petr Mladek 2013-03-13 11:02:21 UTC
it seems to be pretty old problem. I see it even with 3.4.6 build. I did not tested any earlier one.
Comment 4 QA Administrators 2015-02-19 15:46:35 UTC Comment hidden (obsolete)
Comment 5 Jean-Baptiste Faure 2015-02-28 23:13:56 UTC
Same behavior if I try to overwrite a read-only file of mine. Reproduced with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64.

Best regards. JBF
Comment 6 tommy27 2016-04-16 07:28:45 UTC Comment hidden (obsolete)
Comment 7 Jean-Baptiste Faure 2016-05-06 15:33:35 UTC
Nothing changed in LO 5.1.4.0.0+ and master, both build at home under Ubuntu
16.04 x86-64.

Best regards. JBF
Comment 8 QA Administrators 2017-05-22 13:40:30 UTC Comment hidden (obsolete)
Comment 9 Jean-Baptiste Faure 2017-07-24 20:44:50 UTC
Under Ubuntu 16.04 x86-64 and LO 5.4.1.0.0+ I get only one error message.

So closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF