Download it now!
Bug 62306 - Fileopen DOCX: Floating table part inside paragraph shown with paragraph color, not with page background color
Summary: Fileopen DOCX: Floating table part inside paragraph shown with paragraph colo...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.1 rc
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2013-03-13 18:05 UTC by Regina Henschel
Modified: 2019-05-16 16:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Small test file with two small tables (13.68 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-03-13 18:05 UTC, Regina Henschel
Details
Screenshot of the file in MS Word 2010 (14.12 KB, image/png)
2013-03-13 18:06 UTC, Regina Henschel
Details
Test file compared in MSO and LO (105.55 KB, image/jpeg)
2018-10-04 09:52 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2013-03-13 18:05:34 UTC
Created attachment 76489 [details]
Small test file with two small tables

Used  4.1.0.0.alpha0+ (Build ID: 2c9d3817429b1537ea31521cb263a52ce9c7968)

The attached document contains a table with no text wrap and indent -6cm and a second table, which is a floating one with horizontal position left 6cm from page and vertical position 2cm from paragraph.

The attached picture shows how the page looks in MS Word 2010.

The floating table has a wrong horizontal position. The frame around the table contains the first table too, but should not, and the background color should be white.
The first table is not floating and therefore should not have a frame at all, but only the negative indent.
Comment 1 Regina Henschel 2013-03-13 18:06:18 UTC
Created attachment 76490 [details]
Screenshot of the file in MS Word 2010
Comment 2 Jorendc 2013-03-17 21:47:27 UTC
Thanks for reporting!

I can reproduce this behavior using Linux Mint 14 x64 with LibreOffice 4.0.2.1 Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c) and master Version 4.1.0.0.alpha0+ (Build ID: e6a3d1649ce331fd745957f7c0ea039ae27905a).

I mark this bug as Normal High.

Kind regards,
Joren
Comment 3 QA Administrators 2015-02-19 15:39:33 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-03-07 14:25:03 UTC
Confirmed that background color is not white in the lower table.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 5 tommy27 2016-04-16 07:26:33 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2016-10-10 17:59:55 UTC Comment hidden (me-too)
Comment 7 Xisco Faulí 2017-10-03 15:07:30 UTC
Still reproducible in

Version: 6.0.0.0.alpha0+
Build ID: 34e8fd7e99489e9f50a512b07c6f3923b358b4d3
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 8 QA Administrators 2018-10-04 02:55:16 UTC Comment hidden (obsolete)
Comment 9 Timur 2018-10-04 09:52:51 UTC
Created attachment 145367 [details]
Test file compared in MSO and LO

Better than reported. 
Still LO 6.2+ shows floating table background differently from MSO. 
2nd table has "no color" in MSO. So page background should be shown and not blue paragraph.
If table color is set, LO shows it properly.
Comment 10 Xisco Faulí 2019-05-16 16:58:57 UTC
Still reproducible in

Version: 6.3.0.0.alpha1+
Build ID: f897342320ad3a29cf4be1437c8e3ce888bdb3cb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Serge Krot, I thought you might be interested in this issue...