Bug 62324 - FORMATTING: weird selection behaviour if trying to change format
Summary: FORMATTING: weird selection behaviour if trying to change format
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-14 08:26 UTC by Paolo Benvenuto
Modified: 2015-04-07 12:33 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Benvenuto 2013-03-14 08:26:04 UTC
Reproduce it:

- create a whole table (I have 2x10 table)
- format -> paragraph => the selection reduces itself to first cell
Comment 1 Tim Lloyd 2013-03-15 01:10:22 UTC
Hi Paolo, can I just clarify your notes:

select a number of cells within the table
format->paragraph
the selection reduces itself to one cell (ie. the original selection disappears)

Is that what you are reporting as that is what I see?

Can I ask what the ultimate goal is please?

Thanks
Comment 2 Paolo Benvenuto 2013-03-15 06:28:44 UTC
Tim, you understood: when the paragraph format dialog appears, the selection I set reduces to the first cell.

The bug doesn't let me set the formatting of all cells at once.

If instead of format -> paragraph I issue format -> character, the selection is preserved.
Comment 3 NWinkler 2013-09-06 06:20:02 UTC
can't reproduce it on Version: 4.1.1.2
Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903
W7 Prof 64-Bit.

I've created a table 2x10 and selected the whole.
Calling Format Paragraph --> Border and I've choosed "Line arrangement" "Set outer border only"
--> all cells got a double border as expected.
Comment 4 QA Administrators 2015-04-01 14:42:36 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 5 Paolo Benvenuto 2015-04-07 12:33:03 UTC
apparently non present in 4.4.2