Download it now!
Bug 62417 - VIEWING: Writer loads CPU, when I view a LO Draw's diagram
Summary: VIEWING: Writer loads CPU, when I view a LO Draw's diagram
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.1 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-16 16:43 UTC by Denis
Modified: 2015-03-01 08:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
a Writer window and 'top' command's output (134.09 KB, image/png)
2013-03-16 16:43 UTC, Denis
Details
an example (26.70 KB, application/vnd.oasis.opendocument.text)
2013-03-20 03:46 UTC, Denis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis 2013-03-16 16:43:09 UTC
Created attachment 76613 [details]
a Writer window and 'top' command's output

I've created a diagram in LibreOffice Draw, and then I've copied it into Writer.
Now when I'm viewing this diagram in Writer (when I am ONLY VIEWING!), it loads CPU rather high (50-75%).
When I am viewing a simple text, this problem cannot be registered.

On the screenshot at the bottom you can see a Writer window and 'top' command's output.

I think, it is not all right?
Operating System: Ubuntu
Version: 4.0.2.1 rc
Comment 1 Jorendc 2013-03-19 23:33:15 UTC
Hi,

Thanks for reporting.
Is it possible to attach the document, so we can try to reproduce mentioned behavior?

Kind regards,
Joren

Marking this bug as NEEDINFO until respone of Denis
Comment 2 Denis 2013-03-20 03:46:40 UTC
Created attachment 76799 [details]
an example
Comment 3 Denis 2013-03-20 04:02:34 UTC
(In reply to comment #1)
> Hi,
> 
> Thanks for reporting.
> Is it possible to attach the document, so we can try to reproduce mentioned
> behavior?
> 
> Kind regards,
> Joren
> 
> Marking this bug as NEEDINFO until respone of Denis

I've attached a document.
Upd: it it possbie, that the problem is not in Draw diagrams (or not only in it), but also in comments (Insert - Comment, or Ctrl+Alt+C).

P.S. The problem is observing when I scrool the text.
Comment 4 Jorendc 2013-03-20 11:57:33 UTC
I can not reproduce this behavior using Linux Mint 14 x64 with LibreOffice 4.0.2.1. CPU load +/- 10%, seems very good. (Intel® Core™ i5-2300 CPU @ 2.80GHz × 4)

@Denis: please do not mark your own bugs as NEW until it is confirmed by someone independent. But, I didn't say to mark it back to 'UNCONFIRMED' when you provided mentioned information, so this is my bad :-). (but please keep in mind next time :-) ).

@Qubit: you mind testing it using Ubuntu?

Kind regards,
Joren
Comment 5 Jorendc 2013-03-20 12:00:57 UTC
(In reply to comment #3)
> P.S. The problem is observing when I scrool the text.

Mmh, that sounds plausible, because all comments are calculated when the first top of a page is visible. So when you scroll from page 1 to page 2, and arrive at the top of page 2, all comments will be calculated for page 2. But as I see in your screenshot, you already have an high CPU while viewing (without scrolling)... I think that is not god behavior.

Kind regards,
Joren
Comment 6 Denis 2013-03-20 12:53:07 UTC
When I am scrolling the document (with comments and Draw's diagram), it loads CPU vastly - 80-120%. I've tried to remove from the attached document all comments. The situation became better - 30-60%. Then I removed a Draw's diagram. What can I see now? - 25-30%. I've made a video to demonstrate the problem I faced with. It available here: http://ubuntuone.com/7cJ05cqfe2JstiB6S4JnQk

> I can not reproduce this behavior using Linux Mint 14 x64 with LibreOffice
> 4.0.2.1. CPU load +/- 10%, seems very good. (Intel® Core™ i5-2300 CPU @
> 2.80GHz × 4)

I use Xubuntu 12.10 32-bit. Intel Core 2 Duo 2.9 GHz, 2 GB RAM.

> @Denis: please do not mark your own bugs as NEW until it is confirmed by someone independent. But, I didn't say to mark it back to 'UNCONFIRMED' when you provided mentioned information, so this is my bad :-). (but please keep in mind next time :-) 

Roger that :)

> But as I see in your screenshot, you already have an high CPU while viewing (without scrolling)...

This screenshot was made when I was scrooling the document.
Comment 7 Robinson Tryon (qubit) 2013-03-21 07:34:05 UTC
(In reply to comment #4)
> I can not reproduce this behavior using Linux Mint 14 x64 with LibreOffice
> 4.0.2.1. CPU load +/- 10%, seems very good. (Intel® Core™ i5-2300 CPU @
> 2.80GHz × 4)
> 
> @Qubit: you mind testing it using Ubuntu?

Testing on Ubuntu 12.04.2 + LO 4.0.2.1
Hardware has a Core2 CPU @ 2.16GHz x 2 and 2GiB RAM

Noticed a spike up to 30% of CPU when paging through the document quickly, but when only VIEWING the document the CPU usage drops to basically zero (0%).
Comment 8 QA Administrators 2015-02-19 15:41:35 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 9 Jean-Baptiste Faure 2015-03-01 08:53:13 UTC
I do not reproduce the CPU consumption with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64.

Note: my version of LibreOffice doesn't see any Draw object in the bugdoc. Look at the Navigator. Diagrams seem to have been made in Writer itself.

Closing as WorksForMe. Please feel free to reopen as UNCONFIRMED if you disagree.

Best regards. JBF