Bug 62446 - EDITING: Copy/Paste incorrectly copying value/importing on values
Summary: EDITING: Copy/Paste incorrectly copying value/importing on values
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-17 19:01 UTC by Dave Gilbert
Modified: 2013-04-15 18:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Gilbert 2013-03-17 19:01:52 UTC
Problem description: 
Copy/pasting equations is failing for me for copying to more than one destination (in two distinct ways)

Steps to reproduce:
1. Create a new sheet; populate cells A1-A10 with the values 1..10, and cells B1-B10 with the values 10..1
2. Set  C1 as  =B1-A1  and the result 9 is displayed
3. On C1 use Ctrl-c to copy
4. Highlight C2-C10
5. Ctrl-v to paste 

Since that failed I tried:
6. On C1 use Ctrl-c to copy
7. On C2 ctrl-v to paste
8. On C3 ctrl-v to paste

Current behavior:
 5. Displays a 'Text import' dialog
 8. Performs a copy-on-value

Expected behavior:
 5. Should perform a copy-by-equation to each of the cells in the C2-C10 range adjusting the row as appropriate
 8. Should perform a copy-by-equation to C3, adjusting the row, as step 7 did
Operating System: Ubuntu
Version: 4.0.1.2 release
Comment 1 Jorendc 2013-03-18 07:57:36 UTC
Thanks for reporting!

I can not reproduce this behavior using Mac OSX 10.8.3 with LibreOffice 4.0.2.1.

(In reply to comment #0)
> Problem description: 
> Copy/pasting equations is failing for me for copying to more than one
> destination (in two distinct ways)
> 
> Steps to reproduce:
> 1. Create a new sheet; populate cells A1-A10 with the values 1..10, and
> cells B1-B10 with the values 10..1
> 2. Set  C1 as  =B1-A1  and the result 9 is displayed
> 3. On C1 use Ctrl-c to copy
> 4. Highlight C2-C10
> 5. Ctrl-v to paste 

C2-C10 are shown correctly with values in it.
 
> Since that failed I tried:
> 6. On C1 use Ctrl-c to copy
> 7. On C2 ctrl-v to paste
> 8. On C3 ctrl-v to paste
> 
> Current behavior:
>  5. Displays a 'Text import' dialog
>  8. Performs a copy-on-value

formula is copied successfully too.
Comment 2 Dave Gilbert 2013-03-24 17:59:43 UTC
Hi Jorendc,
  Hmm I see what's happening here; this is an interaction with KDE's 'klipper' clipboard manager; I'll ask them if they can see what's going on and see if it's purely on there side or an interaction of the two
Comment 3 Dave Gilbert 2013-03-24 18:31:37 UTC
OK; this happens when using Klipper (KDE clipboard manager) when 'synchronise contents of the clipboard and the selection' is enabled.

It's not clear to me if this is an inevitable side effect of that or not; (gnumeric for example doesn't have the same problem); but I'd be happy for this to be closed if the belief is that's just too weird a thing to do.
Comment 4 Joel Madero 2013-04-15 18:30:54 UTC
This is a klipper issue, I know I've seen similar bug reports that were closed as NOTOURBUG and I believe there are bug reports against klipper that are related.

Closing this as NOTOURBUG as I'm nearly positive it's an issue with Klipper and not LibreOffice