Download it now!
Bug 62485 - Calc: can't put in bold with Ctrl+B after search pattern found using Ctrl+F
Summary: Calc: can't put in bold with Ctrl+B after search pattern found using Ctrl+F
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-18 18:02 UTC by David Winter
Modified: 2017-10-09 13:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Winter 2013-03-18 18:02:13 UTC
Type Ctrl+F to open the search field.
Enter something present in the sheet and press Enter.
Once found, Calc automatically selects the cell. Type Ctrl+B to put it in bold. Instead, Calc continues searching and eventualy asks to search from the begining after reaching the bottom of the sheet.

Workaround: once Calc has selected the cell containing the searched pattern, click again on the cell and Ctrl+B works fine.
Comment 1 Jorendc 2013-05-19 21:15:36 UTC
I tend to mark this as RESOLVED WONTFIX due the fact this is the way the search works. You cursor stays on the search-field during search, this is also the reason why you can use 'ENTER' to go to the next hit... when you press now Ctrl+B you are working in the search-field which has no effect of course. 

Another advantage of this is that you can change your search term very fast while. The only thing you have to do is start typing again ... if you would like to select the cell that a ctrl+B will have effect, you'll start typing in that cell because that cell is selected.

@Joel: any thoughts?

Kind regards,
Joren
Comment 2 Joel Madero 2013-05-20 18:33:40 UTC
Hm, IMO it's a valid enhancement request but not a bug. It is working as designed but it *could* be useful to be able to edit text styles while still in find.

Marking as such:
New
Enhancement
Low - really easy workaround to just click out of find dialog and bold/italicize, etc...

Another option would be to add something in tools->options similar to "fonts" where you can replace anything that meets a certain text (along with wildcards of course) to change the font style/font size/etc...

Joren - hope you agree that it's at least an enhancement request.

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 3 Timur 2017-09-05 14:14:21 UTC
This one was put to New without an explanation how this can be achieved. 
I'm in favor of Comment 1 but I'll let UX decide.
Comment 4 Heiko Tietze 2017-10-09 13:10:35 UTC
The focus remains on the quick search bar because you may want to find next items or refine your search. To leave it just press escape and ctrl+B is functional.