Download it now!
Bug 62511 - PRINTING: Calc document refuses to print after adding a sheet
Summary: PRINTING: Calc document refuses to print after adding a sheet
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Print
  Show dependency treegraph
 
Reported: 2013-03-19 08:43 UTC by oliver_andreas_nowak
Modified: 2018-06-25 14:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice Calc template that demonstrates the behaviour (21.30 KB, application/vnd.oasis.opendocument.spreadsheet-template)
2013-03-19 08:43 UTC, oliver_andreas_nowak
Details
print area new define needed with new table (24.02 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-06-21 22:27 UTC, paulystefan
Details
new ots with table and new defined print area (21.52 KB, application/vnd.oasis.opendocument.spreadsheet-template)
2018-06-21 22:29 UTC, paulystefan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description oliver_andreas_nowak 2013-03-19 08:43:46 UTC
Created attachment 76743 [details]
LibreOffice Calc template that demonstrates the behaviour

Problem description: 

When adding a new table sheet to the attached LibreOffice Calc template (even after saving it as a regular Calc document) LibreOffice won't print the document any more. Neither the print preview nor the File->Print dialog will show any pages to print, even if I attempt to print all table sheets

Steps to reproduce:
1. Open the attached template document
2. Click the print preview button (to see that printing works before modifying the document)
3. (optional) Save the document as a regular Calc document
4. Add a new table sheet to the document (doesn't matter whether you create it via the menu bar on top or the "+"-button at the bottom of the document.
5. Click print preview or File->Print

Current behavior:

After adding a table sheet, LibreOffice won't show any pages to print at all (even after navigating to or selecting multiple other table sheets).

Expected behavior:

The document should be printable like before adding the table sheet.
              
Operating System: Windows XP
Version: 4.0.1.2 release
Comment 1 Jorendc 2013-04-08 21:39:11 UTC
Thanks for reporting

I can reproduce this behavior using Linux Mint 14 x64 with LibreOffice 4.0.2.2 and LibreOffice Version: 4.1.0.0.alpha0+ Build ID: 7b515a57eb6a644860715018656ac0b843b62ba. Therefore I mark this as NEW.

I mark this bug as Major Medium.
Critical: unable to print a document. This is a core function. 
Medium: as far I/we can see only reproducible with this document. If more users can reproduce this behavior with other documents too, we can raise this.

Kind regards,
Joren
Comment 2 A (Andy) 2015-02-26 20:14:18 UTC
Reproducible with LO 4.4.1.2, Win 8.1
Comment 3 tommy27 2016-04-16 07:27:36 UTC Comment hidden (obsolete)
Comment 4 DESAUNAY 2016-06-10 15:52:27 UTC
Checked the 10th of June 2016, with LO, version 5.1.2.2, Windows 10 (and a nice weather outside :-) )
Bug could be found.
Interesting: if you reverse (cancel sheet adding), the bug disappears. If you re-insert a sheet: appears again. Etc...

Voila
Comment 5 paulystefan 2018-06-21 22:27:35 UTC
Created attachment 143020 [details]
print area new define needed with new table

solved for me with LOO 6.0.5.1-64 and win10-64

with new table the print area is undefined

so define print area in new table.

default is none printing of empty tables.
so new table is only printed with some data and defined print area.

all other tables with data needs new define of print area.
Comment 6 paulystefan 2018-06-21 22:29:22 UTC
Created attachment 143021 [details]
new ots with table and new defined print area

LOO 6.0.5.1 win 10-64
Comment 7 paulystefan 2018-06-21 22:31:09 UTC
loss of defined print area  after new table.

workaround: new define of print area in all needed tables
Comment 8 Timur 2018-06-25 14:48:59 UTC
This is an old bug, but it's not correct. 
Document IS printable, only empty sheet is not. 
Not a bug.