Download it now!
Bug 62677 - CONFIGURATION: Mouse positioning option "No automatic positioning" doesn't work
Summary: CONFIGURATION: Mouse positioning option "No automatic positioning" doesn't work
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other Linux (All)
: high minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-23 18:12 UTC by Ross Vandegrift
Modified: 2015-02-20 00:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ross Vandegrift 2013-03-23 18:12:27 UTC
Problem description: 
When a dialog is open, and LibreOffice receives focus, it forces focus and the mouse pointer to the open dialog.  This is a huge frustration when the window manager is configured for focus-follows-mouse.

Under Options -> LibreOffice -> View -> Mouse -> Mouse positioning, one can choose to disable this by selecting "No automatic positioning".

This does disable mouse warping on the initial dialog creation, but it fails to disable the warping when the pointer tries to leave the dialog.

Steps to reproduce:
1. Configure a window manager for focus-follows-mouse.
2. Open any LibreOffice application.
3. Open any LibreOffice dialog box.
4. Try to move the mouse out of the dialog box.

Current behavior:
LibreOffice cruelly forces the pointer back to the dialog box.

Expected behavior:
LibreOffice should not warp my pointer about, especially not after I've disabled automatic mouse positioning!
Operating System: Debian
Version: 4.0.2.1 rc
Comment 1 Joel Madero 2013-03-25 16:07:09 UTC
I've noticed this before also, quite annoying, glad someone took the time to report.

I have been able to confirm the issue on:
Version 3.6.5.2 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Minor - doesn't prevent high quality work but can slow things down and be quite annoying
High - doesn't respect OS settings

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 QA Administrators 2015-02-19 15:47:22 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 3 Ross Vandegrift 2015-02-20 00:00:37 UTC
At QA's prompting, I tested again on 4.3.3.2 from Debian Jessie.

This issue is fixed.  "No automatic positioning" actually disables pointer warping.  But even more, automatic positioning doesn't trap the pointer.

Ross
Comment 4 Joel Madero 2015-02-20 00:23:53 UTC
Hey Ross -

Just wanted to say thank you for taking the time to confirm that the bug no longer exists. We really appreciate it. If you're ever interested in helping out (from beginner tasks to advanced tasks) don't hesitate to jump into our QA Chat: http://webchat.freenode.net/?channels=libreoffice-qa