Bug Hunting Session
Bug 62752 - Bad wmf display in Writer
Summary: Bad wmf display in Writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: preBibisect, regression
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2013-03-26 09:44 UTC by János Korponai
Modified: 2017-07-26 10:53 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
test.odt for the bug (37.90 KB, application/vnd.oasis.opendocument.text)
2013-03-26 09:44 UTC, János Korponai
Details
fig in doc (386.80 KB, image/tiff)
2013-03-26 09:57 UTC, János Korponai
Details
test.odf in loo 4.1.b1 (339.98 KB, image/tiff)
2013-06-02 14:45 UTC, János Korponai
Details
Appearance of the test.odf in oo 3.4.1. (382.74 KB, image/tiff)
2013-06-02 14:50 UTC, János Korponai
Details
wmf test file (145.06 KB, image/wmf)
2014-11-10 11:12 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description János Korponai 2013-03-26 09:44:47 UTC
Created attachment 77037 [details]
test.odt for the bug

I tried to copy a fig into attached test.odt, but the appearance of fig in the document is bad. It is OK in linux and Windows as well.
LOO: Verzió: 3.6.5.2 (Build az.: 5b93205)
Mac OS X: System Version:Mac OS X 10.6.8 (10K549)
Hardware Overview:

  Model Name:	MacBook Pro
  Model Identifier:	MacBookPro7,1
  Processor Name:	Intel Core 2 Duo
  Processor Speed:	2,4 GHz
  Number Of Processors:	1
  Total Number Of Cores:	2
  L2 Cache:	3 MB
  Memory:	4 GB
  Bus Speed:	1,07 GHz
  Boot ROM Version:	MBP71.0039.B0B
Comment 1 János Korponai 2013-03-26 09:57:49 UTC
Created attachment 77039 [details]
fig in doc

appearance of the fig
Comment 2 retired 2013-06-02 09:58:23 UTC
Hi János,

thanks for taking the time to report this. Could you elaborate what the actual problem is? I open the test document and it opens fine. It's a writer document with a graphic that displays correctly from what I can tell.

Could you please check that this bug is still valid using LO 4.1b1 http://www.libreoffice.org/download/pre-releases/. In that case please add sime detailed info about what is going wrong and the exact steps to reproduce the problem.

Setting to OS X due to bug description. Is that correct János?

Thanks :)
Comment 3 János Korponai 2013-06-02 14:45:53 UTC
Created attachment 80155 [details]
test.odf in loo 4.1.b1

The bug seems to be MacOSX specific. Details of graphics are missing.
Comment 4 János Korponai 2013-06-02 14:50:29 UTC
Created attachment 80156 [details]
Appearance of the test.odf in oo 3.4.1.

Graphics of test.odf appear correctly in oo 3.4.1.
Comment 5 János Korponai 2013-06-02 14:57:01 UTC
Hi James,

This bug is still valid using LO 4.1b1. I did not do any special things. I opened the test.odf in writer and it displayed incorrectly.
Comment 6 QA Administrators 2014-02-02 02:07:03 UTC
Dear Bug Submitter,

Please read the entire message before proceeding.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 7 János Korponai 2014-02-02 07:11:58 UTC
The bug is still alive. LO 4.1.4.2
Comment 8 Joel Madero 2014-11-06 03:08:37 UTC
Never confirmed by QA - moving to UNCONFIRMED. Thanks
Comment 9 Alex Thurgood 2014-11-10 10:06:46 UTC
Confirmed on 

Version: 4.4.0.0.alpha2+
Build ID: c1358e5dc875bb923f4b5472ba615ebd19f0d057

the graph is missing
Comment 10 Alex Thurgood 2014-11-10 10:10:01 UTC
@Janos : what kind of image is this ?
Comment 11 Alex Thurgood 2014-11-10 10:12:17 UTC
No graphs shown in 

Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
Comment 12 János Korponai 2014-11-10 10:15:47 UTC
It was copied (copy/paste) from a word doc.
Comment 13 Alex Thurgood 2014-11-10 10:18:40 UTC
    The graph lines display correctly in OOo 321 (build 9502)

    regression
Comment 14 János Korponai 2014-11-10 10:20:26 UTC
on mac?
Comment 15 Alex Thurgood 2014-11-10 10:21:25 UTC
@Janos : Was it a WMF (it gets flagged as such when I want to save it from the ODT in OO 320 ?
Comment 16 Alex Thurgood 2014-11-10 10:22:01 UTC
(In reply to János Korponai from comment #14)
> on mac?

Yes, I'm testing on Mac
Comment 17 János Korponai 2014-11-10 10:22:45 UTC
It is OK on Openoffice 3.4.1 for Mac
Comment 18 Alex Thurgood 2014-11-10 10:26:57 UTC
Confirming also that the graphs are correctly displayed in AOO 411m6 build 9775
Comment 19 retired 2014-11-10 10:31:00 UTC
Still no graphs in LO Version: 4.4.0.0.alpha2+
Build ID: a066acd8709ce69eae4fee3993dbb298e02eb8d5
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2014-11-09_09:59:47
Comment 20 Alex Thurgood 2014-11-10 10:35:47 UTC
On LO 334, the image isn't even displayed, only a frame.

On LO 342, the scales and axes are displayed, but no graphs
Comment 21 Alex Thurgood 2014-11-10 10:38:50 UTC
No graphs in

LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2
Comment 22 Alex Thurgood 2014-11-10 10:42:32 UTC
No graphs in 

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 23 Alex Thurgood 2014-11-10 10:45:31 UTC
So, apparently a bug introduced when LO was created, as it works in OOo 321 and also in AOO 411 (unless they fixed a bug in between with OOo 330).
Comment 24 Alex Thurgood 2014-11-10 11:06:06 UTC
Also displays properly in NeoOffice 341 patch 9
Comment 25 Alex Thurgood 2014-11-10 11:12:48 UTC
Created attachment 109212 [details]
wmf test file
Comment 26 Alex Thurgood 2014-11-10 11:14:24 UTC
Extracted wmf image from test.odt, added as attachment and corected title accordingly
Comment 27 Alex Thurgood 2014-11-10 11:24:02 UTC
@Janos : the only recommendation I can make is to use Apache OpenOffice or NeoOffice instead.
Comment 28 Matthew Francis 2014-12-29 14:48:38 UTC
Adding Cc: to chris.sherlock79@gmail.com

Chris, is this WMF issue of any interest to you?
Comment 29 Chris Sherlock 2014-12-29 15:17:16 UTC
WMF is somewhat different to EMF, but it's interesting nonetheless. I'll take it for now.
Comment 30 Robinson Tryon (qubit) 2015-12-14 05:40:05 UTC Comment hidden (obsolete)
Comment 31 Jean-Baptiste Faure 2016-04-10 08:09:30 UTC
Is this bug still reproducible in LO 5.x for MacOS X ?

Best regards. JBF
Comment 32 János Korponai 2016-04-10 08:26:32 UTC
Yes, this bug is still alive.

Best regards,
Janos

(In reply to Jean-Baptiste Faure from comment #31)
> Is this bug still reproducible in LO 5.x for MacOS X ?
> 
> Best regards. JBF
Comment 33 Jean-Baptiste Faure 2016-04-10 15:19:02 UTC
Changed component from LibreOffice to Writer
Comment 34 Xisco Faulí 2016-09-10 15:57:01 UTC
Hi Chris,
I'm setting this ticket back to NEW as it has been inactive for more than 3
months.
Feel free to assign it back to you if you're still working on this.
Regards
Comment 35 Alex Thurgood 2017-07-26 10:53:19 UTC
With my latest master build

Version: 6.0.0.0.alpha0+
Build ID: 376e27dd498d64212e570354a94c527b37d367b1
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

this is now WFM

probably as a result of EMF/WMF render rework ?