Bug 62809 - 4.0.1 release declared broken by Mac OS X 10.8 after installing language pack
Summary: 4.0.1 release declared broken by Mac OS X 10.8 after installing language pack
Status: RESOLVED DUPLICATE of bug 62442
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-03-27 12:51 UTC by plessard
Modified: 2013-10-21 23:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Error message from OS (51.69 KB, image/png)
2013-04-04 19:18 UTC, plessard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description plessard 2013-03-27 12:51:06 UTC
Problem description: 

Steps to reproduce:
1. Install 4.0.1
2. Immediately install the French resources
3. Launch translated 4.0.1


Current behaviour:
OS pops up a window advising that the app is broken, with choice of cancelling the launch or moving the app to the trash


Expected behaviour:
Ability to launch translated LibO on first try


Workaround:
1. Install 4.0.1
2. Launch UNtranslated 4.0.1
3. Quit LibO
4. Install the French resources
5. Launch translated 4.0.1


Interpretation:
The French translation modifies the file substantially so that the signature provided by The Document Foundation does not fit the file's content. Of course, once the file has been launched the first time Gatekeeper doesn't apply, so LibO can be launched even id modified.


Solution:
The Language installers should also install an updated signature ?
-or-
The Language installers should first launch LibO, quit it, then try to install the language content
-or-
Do like on Windows and pre-install all languages without requiring an independent download.
Operating System: Mac OS X
Version: 4.0.1.2 release
Last worked in: 4.0.0.3 release
Comment 1 plessard 2013-04-04 19:18:54 UTC
Created attachment 77440 [details]
Error message from OS
Comment 2 plessard 2013-04-04 19:20:05 UTC
I downloaded and installed 4.0.2 today, with the same results.
Comment 3 Joel Madero 2013-04-15 18:51:57 UTC
Michael - install bug, looks quite serious, ideas on it? -- not confirmed but wanted to raise it to your attention as it could be a blocker if it's ours
Comment 4 Michael Meeks 2013-04-16 09:03:01 UTC
Nasty indeed; I guess Tor is the expert here.
I imagine the problem comes from the lang-packs. Perhaps we are signing those individually, but they interact unpleasantly with the app signing - do we need to install them somewhere separate somehow ?
Comment 5 Don't use this account, use tml@iki.fi 2013-04-16 10:28:51 UTC
I don't build the TDF builds, so sorry, no idea.
Comment 6 retired 2013-05-13 09:38:50 UTC
WORKSFORME

hi all, tried reproducing this on OS X 10.8.3. But everything is fine after installing LO 4.0.3.3 and the french language resources.

@plessard: Feel free to re-open this bug, should this problem be reproducible for you with the latest LO 4.0.3.3.
Comment 7 plessard 2013-05-16 17:54:34 UTC
I can confirm that the bug isn't resolved as I attempted to install LO 4.0.3.3 on a Mac with 10.8.3 and I got the same error message.

Note that to get the message you MUST NOT open LibreOffice between the install/copy to the Application folder and the installation of the language file(s).

In other words :

Steps to reproduce:
1. Install 4.0.3
2. Immediately install the French resources
3. Launch translated 4.0.3

But not this way :
1. Install 4.0.3
2. Launch UNtranslated 4.0.3
3. Quit LibO
4. Install the French resources
5. Launch translated 4.0.3
Comment 8 retired 2013-10-10 21:39:37 UTC
Plessard: Is this still an issue with LO 4.1.2? http://www.libreoffice.org/download
Comment 9 Tor Lillqvist 2013-10-15 14:45:01 UTC

*** This bug has been marked as a duplicate of bug 62442 ***
Comment 10 plessard 2013-10-21 23:44:33 UTC
Yes, the bug is still present : I check each time I install an update ! ;-)

And I agree that this bug is a duplicate of the bug 62442