Download it now!
Bug 62818 - VIEWING: Start window incompatible with colour scheme contrast black
Summary: VIEWING: Start window incompatible with colour scheme contrast black
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-27 15:16 UTC by gzernmplatz
Modified: 2015-03-02 02:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the starting screen of LibreOffice in my colour scheme (59.95 KB, image/png)
2013-04-09 13:04 UTC, gzernmplatz
Details
Screenshot (210.36 KB, image/png)
2013-04-09 13:14 UTC, Florian Reisinger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gzernmplatz 2013-03-27 15:16:02 UTC
Problem description: When I have the colour scheme "Kontrast schwarz" (contrast black) and start LibreOffice, the window in the middle is white on white - see attached screen shot.

Steps to reproduce:
1. Set colour scheme contrast black
2. Start LibreOffice

Operating System: Windows 7
Version: 4.0.1.2 release
Comment 1 Jorendc 2013-04-08 22:00:58 UTC
(In reply to comment #0)
> Problem description: When I have the colour scheme "Kontrast schwarz"
> (contrast black) and start LibreOffice, the window in the middle is white on
> white - see attached screen shot.

Is it possible to attach a screenshot, so we can see what's the issue?

Thanks in advance,
Joren

PS: please feel free to mark this bug back to UNCONFIRMED once you attached the screenshot.
Comment 2 gzernmplatz 2013-04-09 13:04:03 UTC
Created attachment 77664 [details]
Screenshot of the starting screen of LibreOffice in my colour scheme
Comment 3 Florian Reisinger 2013-04-09 13:14:45 UTC
Created attachment 77665 [details]
Screenshot

Tested with master: Version: 4.1.0.0.alpha0+
Build ID: 61d1f8f237bb45901de9c8016ea48fab1c3570d IMHO easy to fix --> You just need to set the hover color of the text to white....
Comment 4 gzernmplatz 2013-04-09 14:39:27 UTC
Could you please explain what "hover colour" means and how I can change it?
Comment 5 Florian Reisinger 2013-04-09 17:16:49 UTC
Sorry the "you" is not you as a person, it is rather someone (a dev)...
Comment 6 Jan Holesovsky 2013-04-18 07:43:19 UTC
Florian: So the problem seems to be this:

http://cgit.freedesktop.org/libreoffice/core/tree/framework/source/services/backingwindow.cxx#n459

Instead of forcing the color to something exact, we should use the black version of the background bitmap too.  We seem to have it:

http://cgit.freedesktop.org/libreoffice/core/tree/icon-themes/hicontrast/brand/shell

Please try to find out why it is not used in this case; if you have trouble, please poke me on the IRC again :-)
Comment 7 Florian Reisinger 2013-04-18 10:11:43 UTC
Thanks for the pointer. I will try some things :)
Comment 8 Florian Reisinger 2013-04-20 16:33:18 UTC
Did some research:

1)WINDOWS only
2)Although the font color is forced to black it works on Linux

Hope that helps someone else :)
Comment 9 Adolfo Jayme 2015-03-02 02:59:58 UTC
(We should have a RESOLVED OBSOLETE bug status.)

This is no longer relevant since the implementation of the new start center.