Bug 62946 - scrolling with mouse crashes X
Summary: scrolling with mouse crashes X
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-30 22:24 UTC by petrelharp
Modified: 2013-04-08 13:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
backtrace of the crash (23.34 KB, text/plain)
2013-04-06 15:34 UTC, petrelharp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description petrelharp 2013-03-30 22:24:10 UTC
Highly reproducible, but machine-specific: on a Thinkpad E530c:

Behaviour:
 1) open Writer, new document, and ctrl-enter to add three or four pages
    -- or else: open any document with more than a few pages.
 2) scroll down, then up with the touchpad
 3) X freezes; sometimes freezing completely; sometimes hanging the GPU.

I have two machines, both runnning up-to-date Debian Sid; the Thinkpad E530c does this, making Writer difficult to use; the Thinkpad T420i has no problems.

This happens in both LO 4.0.1 and 3.5.4.2, the version in the Debian sid repositories.

I filed this as a bug against the debian xserver-xorg-video-intel package some time ago (for logs, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=703749 ), but: there's been no movement; and this only occurs with Libreoffice, so I am posting it here to find out how to tell if the bug is with LO or with X somehow.  Please let me know how to diagnose this.

thanks,
  --p
Comment 1 Julien Nabet 2013-04-06 08:53:54 UTC
petrelharp: could you try to retrieve a backtrace? (see https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_on_Linux)
Comment 2 petrelharp 2013-04-06 15:34:02 UTC
Created attachment 77532 [details]
backtrace of the crash

The SIGTERM is because I had to ssh in (frozen X) and kill soffice to get this.

Let me know if there's more info needed.
Comment 3 Julien Nabet 2013-04-06 15:42:13 UTC
petrelharp: thank you for your feed back, it might be useful indeed!
http://opengrok.libreoffice.org/xref/core/vcl/unx/generic/app/wmadaptor.cxx#2194
   2206         if( XGetWindowProperty( m_pDisplay,
   2207                                 aWindow,
   2208                                 m_aWMAtoms[ NET_WM_DESKTOP ],
   2209                                 0, 1,
   2210                                 False,
   2211                                 XA_CARDINAL,
   2212                                 &aRealType,
   2213                                 &nFormat,
   2214                                 &nItems,
   2215                                 &nBytesLeft,
   2216                                 &pProperty ) == 0
   2217                                 && pProperty
   2218         )
   2219         {
   2220             nCurrent = int(*(sal_Int32*)pProperty);
   2221             XFree( pProperty );
   2222         }
   2223         else if( pProperty )
   2224         {
   2225             XFree( pProperty );
   2226             pProperty = NULL;
   2227         }
I noticed a double cast line 2220, I don't know if it's normal or not, perhaps it is.
Maybe pProperty should be put to NULL also in "if" block?

Caolán: one for you?

Put it at New since we got a bt.
Comment 4 Caolán McNamara 2013-04-08 12:25:35 UTC
Unfortunately this appears to be a bug on the other side, and there doesn't seem to be much we can do about it.
Comment 5 petrelharp 2013-04-08 13:23:19 UTC
Can you tell where the bug is -- is it the intel drivers, or elsewhere?  Any other information that might be useful?

thanks a bunch,
  p.