Bug 63063 - TexMaths V 0.37: equations crated with LO 3.4.3 causes BASIC runtime error
Summary: TexMaths V 0.37: equations crated with LO 3.4.3 causes BASIC runtime error
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
(earliest affected) release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Keywords: notBibisectable, regression
Depends on:
Reported: 2013-04-03 08:58 UTC by Noam
Modified: 2015-12-17 10:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

A Hebrew document with equations created by Libreoffice 3.4.3 (22.19 KB, application/vnd.oasis.opendocument.text)
2013-04-03 08:58 UTC, Noam

Note You need to log in before you can comment on or make changes to this bug.
Description Noam 2013-04-03 08:58:24 UTC
Created attachment 77368 [details]
A Hebrew document with equations created by Libreoffice 3.4.3

Problem description: 
Each time I try to edit an equation in a document I've created with Libreoffice 3.4.3 and TexMaths I get a Libreoffice error message:
"BASIC runtime error.
Property or method not found: getAnchor."

Steps to reproduce:
1. Open a document created with Libreoffice 3.4.3
2. Select an equation created with TexMathsand click on TexMaths button.
3. Do nothing or edit the equation within TexMaths window
4. Click on LaTex button.

Current behavior: getting the error message mentioned above

Expected behavior: placing the equation in the document

Operating System: Windows XP
Version: release
Last worked in: 3.4.3 release
Comment 1 Rainer Bielefeld Retired 2013-04-03 09:18:25 UTC
With what Noam TexMaths Version has the document been created, what one do you use now?
It seems LaTex is required for that Extension? What LaTex Version do you use?
Please contribute ALL information required to reproduce your problem
Comment 2 Rainer Bielefeld Retired 2013-04-03 14:33:00 UTC
I can confirm the reported Problem with 
* parallel Dev-installation of  "Version (Build ID: 049ce78144650d92eb6bd73292868f73d37c901) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-03-29_23:59:42" ENGLISH UI / German Locale on German WIN7 Home Premium (64bit) with LODev/4 Masters User Profile 
* basic-miktex-2.9.4813-x64
* TexMaths 0.37

My experience: I was asked to install an additional package, then LibO became unresponing fror 10s, then "BASIC runtime error.
Property or method not found: getAnchor."

I will contact Author, may be he will find faster what the problem is.
Comment 3 Rainer Bielefeld Retired 2013-04-03 14:36:04 UTC
I hope you are the author? It would be great if you could help to debug!
Comment 4 Roland Baudin 2013-04-04 19:07:40 UTC
Yes, I am the author...
This bug is probably related to Windows, because everything works well on Linux. I'll try to fix it using a VirtualBox install.
Comment 5 Rainer Bielefeld Retired 2013-04-04 20:27:53 UTC
bugzilla-daemon@freedesktop.org schrieb:

> I'll try to fix it using a VirtualBox install.

Hi Roland,

thank you very much, please send a ping if you think support might be 
useful (Master tests on a real machine, ...).

Best regards

Comment 6 sharkcow 2013-04-12 19:50:38 UTC
I don't know if this is related, but I do get the same error message on a linux install. When I open a document created with Openoffice about a year ago containing equations created with OOLatex, I can't modify the equations with TexMaths due to the "getAnchor" error.

Comment 7 retired 2013-06-01 19:10:02 UTC
Setting to NEW as of comment 2 and 6.

@Roland: Any news regarding this? Feel free to update the status of this bug if there's anything new.

Thanks :)
Comment 8 retired 2014-11-10 10:59:05 UTC
How is this reproduced? What is TextMath? Is it an extension that needs to be installed? What is "Latex button".

Would be great to have more detailed reproduce steps so this can also be tested by QA volunteers who are not professional math users and have never heard of terms like TextMath or Latex button :)

Does this persist with the latest nightly under a newer OS than WinXP (which by now is EndOfLife and should not be used).

Comment 9 QA Administrators 2015-09-04 02:55:35 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-09-03
Comment 10 Noam 2015-09-05 15:02:12 UTC
I didn't encounter this bug for a long time now
I guess that with the updated versions of LibreOffice and TexMaths it is now fixed.
Thanks for the good work.
Comment 11 Robinson Tryon (qubit) 2015-12-17 10:55:07 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)