Download it now!
Bug 63125 - The HTML export of a Writer Document containing WMF image will not contain the image
Summary: The HTML export of a Writer Document containing WMF image will not contain th...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: low critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-04 15:03 UTC by Sorinello
Modified: 2015-03-24 13:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Case in ODT format (75.56 KB, application/vnd.oasis.opendocument.text)
2013-04-04 15:03 UTC, Sorinello
Details
Exported WMF in GIF (how it looks and is bad) (4.82 KB, image/gif)
2013-04-04 15:04 UTC, Sorinello
Details
Exported PNG (how it should look) (61.06 KB, image/png)
2013-04-04 15:04 UTC, Sorinello
Details
Initial WMF file used (4.98 KB, image/x-wmf)
2013-04-04 15:05 UTC, Sorinello
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sorinello 2013-04-04 15:03:58 UTC
Created attachment 77427 [details]
Test Case in ODT format

When saving to HTML a writer document which contains a WMF file which has text
in it, the image quality of the text gets bad and worse than an image export of
the same WMF file or worse than what you see on screen in LibreOffice. This only
happens to text that is on it's own but not on text inside a box (in the case of
an LibreOffice Draw document).

This is reproduced with a WMF document created with LibreOffice Draw but is also
the case with WMF documents from external sources.

This has  been reproduced in LibreOffice 3.6.22 and 4 on Linux.
I believe it is happening on all platforms and all versions that I've tried with. 

How to reproduce with the provided OO doc:

1/ Take the LibreOffice word file 

2/ View in open office and see that both images look good. The first one is WMF.
The second one PNG.

3/ Save as HTML

4/ View the 2 images. The PNG is looking good. The WMF is transformed to GIF and
looks bad. Notice the text in the blue box is ok. Notive the other text seem
bold or seems like the text is there twice with 1 pixel horizontal shift

5/ In OO use right click button on the first image and use "Save Graphics". Save
to GIF or PNG. View the resulting image which looks good (the issue does not
seem related to the fact that the save to html is GIF)

How to reproduce from Scratch:

1/ Open LibreOffice Draw and make a using the "font" feature to type a text

2/ Use "Export" / Choose Selection to export once in WMF and once in PNG

3/ Create an LibreOffice Writer document and include both images WMF and PNG

4/ Follow inscrutions on how to reproduce in the previous paragraph.

I will atach files showing the problem:

- ODT with WMF and PNG
- Initial WMF
- Initial PNG
- Exported PNG
- Exported WMF in GIF

These files are created with LibreOffice 4.0 on Ubuntu 12.10.
Comment 1 Sorinello 2013-04-04 15:04:22 UTC
Created attachment 77428 [details]
Exported WMF in GIF (how it looks and is bad)
Comment 2 Sorinello 2013-04-04 15:04:43 UTC
Created attachment 77429 [details]
Exported PNG (how it should look)
Comment 3 Sorinello 2013-04-04 15:05:10 UTC
Created attachment 77430 [details]
Initial WMF file used
Comment 4 Jorendc 2013-04-08 21:51:07 UTC
Thanks for reporting!

When I export the attached odt file as html with Linux Mint 14 x64 and LibreOffice 4.0.2.2, and open it using Firefox 20 the wmf file is gone? As far I understand your bug reported well, you see a 'bad rendered image'?

Kind regards,
Joren
Comment 5 Sorinello 2013-04-11 12:29:04 UTC
Hello Jorendc.

Yes, The bug report was a little bit misleading. Like you, I don't get any image in the HTML file. It seems that WMF export to HTML is totally broken.

To reproduce:

Open LO Writer and insert the Initial WMF file used (see attachment), and then export the page as HTML.
Comment 6 Jorendc 2013-04-11 12:34:02 UTC
(In reply to comment #5)
> Hello Jorendc.
> 
> Yes, The bug report was a little bit misleading. Like you, I don't get any
> image in the HTML file. It seems that WMF export to HTML is totally broken.

Thanks for your feedback.

As I mention in Comment 4 I can reproduce that. Therefore I mark this as NEW.

Priority:
- Critical: Data loss
- Low: not that many used by that many users.

Kind regards,
Joren
Comment 7 QA Administrators 2015-03-04 02:22:29 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 8 Buovjaga 2015-03-24 13:39:10 UTC
The HTML saved now shows the WMF (converted to in-line PNG) and the text is not bad like in the gif. Closing as WFM.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI