Bug 63141 - Spanish translation replaces Heading (Encabezado) with Header (Encabezamiento)
Summary: Spanish translation replaces Heading (Encabezado) with Header (Encabezamiento)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Adolfo Jayme
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-05 00:30 UTC by Francisco
Modified: 2013-10-04 23:28 UTC (History)
1 user (show)

See Also:


Attachments
ODT example created with LibO 3.5.7 (26.78 KB, application/vnd.oasis.opendocument.text)
2013-04-05 00:30 UTC, Francisco
Details
Screenshot of the file created and viewd with LibO 3.5.7 (171.41 KB, image/jpeg)
2013-04-05 00:31 UTC, Francisco
Details
Screenshot of the file viewed with LibO 4.0.2 with english UI (169.00 KB, image/jpeg)
2013-04-05 00:32 UTC, Francisco
Details
Screenshot of the file viewed with LibO 4.0.2 with spanish UI (171.39 KB, image/jpeg)
2013-04-05 00:33 UTC, Francisco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2013-04-05 00:30:26 UTC
Created attachment 77459 [details]
ODT example created with LibO 3.5.7

Since LibO 3.6, all headings of my files saved with prior LibO version looked smaller. It still happens with LibO 4.0

I could not realize what was happening until today, that I downloaded LibO 4.0.2 and didn't use the translated UI.
I will try to describe the problem carefully, attaching a ODT file and 3 screenshots.

System: Kubuntu 12.04, with LibO 3.5.7 installed from repositories

Description:
The first screenshot shows a file created with LibO 3.5.7 installed from Kubuntu repos. All formating is done through styles.
So, the header has a the "Header style" (translated as Encabezamiento en LibO 3.5 and prior), headings has their conrresponding "Heading styles" (Encabezados), and so for bodytext. 

The styles used in this file are:
· Encabezado/Heading: Liberation Sans 14 pts
· Encabezados/Heading 1: 115% of Heading = 16.1 pts
· Encabezamiento/Header: 9 pts

The second screenshot shows this file opened with LibO 4 without the spanish translation. It shows a correct formating of the file, with exactly the same styles as defined in files saved with LibO 3.5.

The third screenshot shows the same file opened with LibO 4 but having already installed the translated UI.
Now, the styles has become
· Encabezado/Heading: Liberation Sans 9 pts (as was Header)
· Encabezados/Heading 1: 115% of Heading = 10.3 pts
· Encabezamiento/Header: doesn't exist


So, the problem is that the spanish translation is using "Header" in place of "Heading". When saving this file with LibO 4 with spanish UI, opening with Lib 3.5 looks also wrong, with the modified styles.
Comment 1 Francisco 2013-04-05 00:31:24 UTC
Created attachment 77460 [details]
Screenshot of the file created and viewd with LibO 3.5.7
Comment 2 Francisco 2013-04-05 00:32:27 UTC
Created attachment 77461 [details]
Screenshot of the file viewed with LibO 4.0.2 with english UI
Comment 3 Francisco 2013-04-05 00:33:59 UTC
Created attachment 77463 [details]
Screenshot of the file viewed with LibO 4.0.2 with spanish UI
Comment 4 Adolfo Jayme 2013-04-05 22:38:10 UTC
Self-assigning. I’m investigating the problem right now, thanks for your bug report.
Comment 5 Francisco 2013-05-10 03:38:26 UTC
This bug still present in LibO 4.0.3 on Kubuntu 64 bits.
Comment 6 Adolfo Jayme 2013-06-28 21:06:51 UTC
OK, I’m slowly fixing the translations, and will appear in 4.1. But I think LibreOffice’s styles should not break when translations change, but I’m not a programmer and don’t know how to fix that.

Sorry for neglecting this for so long, but I had a hardware failure and was unable to do any significant work on LibreOffice.
Comment 7 Francisco 2013-06-28 21:30:03 UTC
Hi Adolfo.

May I help in something? I haven't work a lot translating programs, just helped once with the translation of the KDE version of "UFW KControl Module".
By the way, did you find the problem? I mean, what happened?
Comment 8 Adolfo Jayme 2013-07-01 20:02:42 UTC
Hm, I wonder if this is related to bug #61339 - I hope so.

Francisco, thank you for your offer. I think I just need to be more organized, and actually finish my duties :-P

You were correct wrt the translation mixing the terminology up.
Comment 9 Francisco 2013-09-30 03:38:36 UTC
Adolfo, firt of all, thank you. And may I ask when this change will be ready? ;-)
Comment 10 Adolfo Jayme 2013-09-30 16:30:16 UTC
I fixed the translations before 4.1 release, but forgot to update this bug :-P But I don't know if your documents will show up correctly, though.
Comment 11 Francisco 2013-10-04 23:28:44 UTC
(In reply to comment #10)
> I fixed the translations before 4.1 release, but forgot to update this bug
> :-P But I don't know if your documents will show up correctly, though.

I have checked LibO 4.1.2 today, and the bug is fixed. Thank you very much, Aldolfo!