Bug 63142 - Outlining, Promote, Demote does not work
Summary: Outlining, Promote, Demote does not work
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 Beta0
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2013-04-05 00:31 UTC by Dave Nadler
Modified: 2019-12-03 18:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
illustration for outlining problems (76.10 KB, application/vnd.oasis.opendocument.presentation)
2013-04-05 00:33 UTC, Dave Nadler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Nadler 2013-04-05 00:31:29 UTC
Open the example document slide 2.

1) Click anywhere in the document.
Promote/demote buttons are not working (grayed out)

2) View Slide Master
- highlight all text in main window
- "Format, Bullets and Numbering"
- select Position tab
- highlight level 4
- set indent ".20" with "relative" checked
- click OK
Doesn't work: open same dialog again and you'll see it didn't stick;
indent remains a large number


Thanks !
Best Regards, Dave
Comment 1 Dave Nadler 2013-04-05 00:33:03 UTC
Created attachment 77462 [details]
illustration for outlining problems
Comment 2 A (Andy) 2013-04-06 09:07:19 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 3 Björn Michaelsen 2013-04-22 11:41:24 UTC
I can reproduce this on 4.0.2.2 on Ubuntu raring distro build and on master at 95c586d5c034115fd252c5fb0e4637bf9dc68a4d.

Note this is not related to a document, promote/demote seems to not work in general in Impress.
Comment 4 tommy27 2013-04-22 12:32:28 UTC
did it work in previous 3.6.x and 4.0.x releases?
Comment 5 Björn Michaelsen 2013-04-22 13:17:22 UTC
bibisect shows this was already broken at d6cde02dbce8c28c6af836e2dc1120f8a6ef9932 (2011-08-22). setting version to 3.5.0beta0 as this is _at least_ that old.
Comment 6 Andras Timar 2013-04-22 19:28:12 UTC
This slide is strange a bit, layout is "Blank Slide". When I choose e.g. layout "Title, Content" and copy the contents of the slide, promote/demote both work.
Comment 7 Thorsten Behrens (CIB) 2013-04-23 09:36:00 UTC
So - is that a broken document, wrong expectation, bad UI? At least a random fresh document here does what I'd expect.
Comment 8 Dave Nadler 2013-04-29 17:55:33 UTC
The original document was produced in PowerPoint; I'm trying
to switch work to LibreOfice - same situation as many users.

Is the inability to set the indent level (item (2) in my original post)
a different problem or related ??

Thanks,
Best Regards, Dave
Comment 9 Robinson Tryon (qubit) 2015-12-14 05:40:04 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2016-09-14 14:50:54 UTC
Only regressions should use the keyword 'preBibisect'. Removing it...
Comment 11 Xisco Faulí 2017-09-29 08:48:56 UTC Comment hidden (obsolete)
Comment 12 go2null 2017-12-14 09:04:28 UTC
Bug still exists.
  Version: 5.4.3.2
  Build ID: 40m0(Build:2)
  CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
  Locale: en-US (en_US.UTF-8); Calc: group

Running on Void Linux MUSL
Comment 13 QA Administrators 2018-12-15 03:56:00 UTC Comment hidden (obsolete)
Comment 14 Thomas Lendo 2019-05-05 11:31:39 UTC
Bug still present in 

Version: 6.3.0.0.alpha0+
Build ID: 98630a0bd49bd80652145a21e4e0d0ded792b36b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-04_04:44:35
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded
Comment 15 Timur 2019-12-03 18:03:29 UTC
Working in LO 6.2.8 and master 6.5+. Test in windows.
Note I used promote/demote from Sidebar and Format/Bullets and Numbering is changed in master.
But I couldn't reproduce 2) with LO 5.0 so I'm not sure. 
Should you reproduce again, please explain and set New.