Download it now!
Bug 63145 - Opening DOCX with Mirror/Gutter, Page Layout is reverted to "Right and Left"
Summary: Opening DOCX with Mirror/Gutter, Page Layout is reverted to "Right and Left"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 63143 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-05 01:04 UTC by john.jakus
Modified: 2015-04-01 16:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john.jakus 2013-04-05 01:04:53 UTC
Opening DOCX with Mirror/Gutter, Page Layout is reverted to "Right and Left"

This happens if the document was created in LibreOffice Writer 4.0.2 and prior or MS Office Word 2013.

Scenario 1:
I created an OpenXML (DOCX) document in MS Word 2013. I set "Multiple Pages" (Margins) to "Mirror Margins". I set Left Margin .5", Right Margin .5" and Gutter .5". Save document and verify. I should get an outer margin as .5" and inner as 1"

Open in LibreOffice 4.0.2.2 and prior. The "Page Layout" is reverted to "Right and Left" The margin left and right margins are reverted to .79"

Scenario 2:
I create an OpenDocument (ODT) document in LibreOffice 4.0.2.2 and prior. I set "Page Layout" to "Mirrored". I set inner to 1" and outer to .5". Save document. Open Document and Page Layout is still Mirrored and margins are correct.

I then save the document as OpenXML (DOCX). Margins still look good while open. I close the document and open again with LibreOffice 4.0.2.2 and the "Page Layout" is reverted to "Right and Left"

Scenario 3:
I use the OpenDocuemnt (ODT) Document created in Scenario 2. Open the document in LibreOffice 4.0.2.2. The "Page Layout" is set to mirrored. Inner margin 1" and outer margin is .5". Looks normal.

I open the OpenDocument (ODT) in MS Word 2013. Open Page Setup. "Multiple Pages (Margins)" is set to Normal. Left margin is 1" and right margin is 0.5".

Scenario 4:
I open the OpenXML (DOCX) Document created in Scenario 2 by LibreOffice with MS Word 2013. Open Page Setup. "Multiple Pages" is set to normal and Left margin is 1" and right margin is 0.5".

Seems that LibreOffice may be saving and reading DOCX margin info in/from the wrong location of the XML files
Comment 1 john.jakus 2013-04-05 01:06:06 UTC
I forgot to add when opening the DOCX and ODT in MS Word 2013, the Gutter is 0.
Comment 2 Jorendc 2013-04-05 23:05:58 UTC
I can reproduce this behavior using Mac OSX 10.8.3 with LibreOffice 4.0.2.2. Therefore I mark this as NEW.

Thanks for your detailed research!

Kind regards,
Joren
Comment 3 john.jakus 2013-04-08 16:01:13 UTC
Joren,

To test this properly, you may need to use MS Office 2013 (version 15) for the Office side as it's the only MS Office version that currently supports ODF 1.2. Using MS Office 2010 (Version 14) and below only supported ODF 1.1. Also I do not think that ODF 1.2 will be supported in MS Office for MAC until version 2014.

That being said, the margin issues may not matter if it's ODF 1.1. or 1.2? Not sure.

Cheers,

John
Comment 4 Jorendc 2013-04-08 16:04:33 UTC
*** Bug 63143 has been marked as a duplicate of this bug. ***
Comment 5 Jorendc 2013-04-08 16:11:19 UTC
(In reply to comment #3)
> To test this properly, you may need to use MS Office 2013 (version 15) for
> the Office side as it's the only MS Office version that currently supports
> ODF 1.2. Using MS Office 2010 (Version 14) and below only supported ODF 1.1.
> Also I do not think that ODF 1.2 will be supported in MS Office for MAC
> until version 2014.
Probably (if there would be a 2014 version? I just don't know yet :-) ). Even an ODF 1.1 isn't supported with Word for Mac 2011. But I did some test using Word for Mac 2011 and LibreOffice and I came to the same conclusion as mentioned here and in (as far I can see duplicate) Bug 63143.

> That being said, the margin issues may not matter if it's ODF 1.1. or 1.2?
> Not sure.
It shouldn't matter, no. 

kind regards,
Joren
Comment 6 Jorendc 2013-05-13 20:16:18 UTC
The bug version is the oldest version you can reproduce the bug. Therefore I restore the version number.

Kind regards,
Joren
Comment 7 QA Administrators 2015-03-04 02:20:18 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 8 Buovjaga 2015-04-01 16:01:03 UTC
No problem anymore with scenarios 1, 2 and 4. Scenario 3 is not our bug.
Setting to WFM.

Win 8 32-bit
MSO 2013
LibreOffice Version: 4.5.0.0.alpha0+
Build ID: 4dde5a623d563f9007dd3539b835489a27128d65
TinderBox: Win-x86@42, Branch:master, Time: 2015-04-01_11:40:51
Locale: fi_FI