Download it now!
Bug 63185 - EDITING TABLE: FORMATTING alignment "right" in cell lost in Text to TABLE conversion
Summary: EDITING TABLE: FORMATTING alignment "right" in cell lost in Text to TABLE con...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-05 17:44 UTC by Rainer Bielefeld Retired
Modified: 2015-03-15 21:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (15.95 KB, application/vnd.oasis.opendocument.text)
2013-04-05 17:44 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-04-05 17:44:37 UTC
Created attachment 77496 [details]
Sample Document

Found this one during my research for "FORMATTING: Paragraph alignment "right" lost in TABLE to text conversion".

Steps how to reproduce [Reproducible] with  "LibreOffice 3.6.6.2 rc " German UI/ German Locale [Build-ID: f969faf] {pull date 2013-04-03} on German WIN7 Home Premium (64bit):

1. Open attached Sample document
2. Under Heading "And there is an additional problem" select text with tabs
   " left	right	left	right
     left	right	left	right"
3. Menu 'Table -> Convert -> Text to Table'
   Expected: "right" will be aligned at the right in cells
   Actual: all text left aligned

Opposite direction works fine.

That never worked correctly in LibO / OOo at least back until 1.1.5., and also Symphony and OOo 4 fail.

But SoftMaker FreeOffice does a perfect job with my enhanced test document I created based on reporter's.


@Serhiy:
Can you confirm my results?
Comment 1 Rainer Bielefeld Retired 2013-04-05 17:51:29 UTC
Only for the sake of completeness: Still reporducible with Version 4.1.0.0.alpha0+ (Build ID: 049ce78144650d92eb6bd73292868f73d37c901)
TinderBox: Win-x86@6, Branch:master, Time: 2013-03-29_23:59:42
Comment 2 A (Andy) 2013-04-05 21:12:09 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 3 QA Administrators 2015-03-04 02:23:08 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 4 Serhiy 2015-03-05 22:09:04 UTC
LO 4.4.1.2, Windows 7 x64
During converstion right aligned text to table, the paragraphs in table keep right alignment. So the bug isn't present in LO 4.4.1.2.

Somehow in bug Status I have only RESOLVED, but no RESOLVED-WORKSFORME, so I leave the status as it is. Who can change the status to RESOLVED-WORKSFORME, please, do this instead of me.
Comment 5 Jean-Baptiste Faure 2015-03-15 21:19:53 UTC
(In reply to Serhiy from comment #4)
> LO 4.4.1.2, Windows 7 x64
> During converstion right aligned text to table, the paragraphs in table keep
> right alignment. So the bug isn't present in LO 4.4.1.2.
> 
> Somehow in bug Status I have only RESOLVED, but no RESOLVED-WORKSFORME, so I
> leave the status as it is. Who can change the status to RESOLVED-WORKSFORME,
> please, do this instead of me.

Thank you for the test.
Once you have chosen RESOLVED, you can add WORKSFORME.
Closing.

Best regards. JBF