Download it now!
Bug 63229 - Hyperlink in PDF
Summary: Hyperlink in PDF
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-07 12:47 UTC by JO
Modified: 2016-05-02 23:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
odt test file (9.64 KB, application/vnd.oasis.opendocument.text)
2013-04-08 16:22 UTC, Jorendc
Details
exported pdf file (20.15 KB, application/pdf)
2013-04-08 16:22 UTC, Jorendc
Details
Testfiles to detect the Hyperlinkmistake (536.73 KB, application/zip)
2013-04-09 20:11 UTC, JO
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JO 2013-04-07 12:47:52 UTC
Hi,
if a Hyperlink-Adress in an odt-document contains mutated vowels like ä,ö,ü and the dokument will be exported in to a pdf-document then there are wrong signs in the pdf-Adress (ä to %3..)and therefore it does not work! 
JO
Comment 1 Jorendc 2013-04-08 16:22:05 UTC
Hi,

Thanks for reporting.
I can reproduce this behavior using Linux Mint 14 x64 with LibreOffice 4.0.2.2 and LibreOffice Version: 4.1.0.0.alpha0+ Build ID: 7b515a57eb6a644860715018656ac0b843b62ba (build today).

Therefore I mark this as NEW.

@JO: adding an attachment that shows the behavior and steps how to create this behavior from scratch will be useful. Please do next time :-).

How to reproduce:
* Open Writer
* Insert > Hyperlink
* Add a target URL. For example: http://www.ümlaut.de
* Apply, Close
* Deselect the link
* Insert another link, now to a website without mutated vowel. For example: http://www.libreoffice.org
* Export as PDF
* Save as ODT

Behavior:
* Ctrl+click on both link works (in Writer).

Open PDF. Behavior:
* Click on the first link redirects me to the folder where this file is stored
* Click on the second link opens my web browser correctly (firefox in my case).

Kind regards,
Joren
Comment 2 Jorendc 2013-04-08 16:22:25 UTC
Created attachment 77610 [details]
odt test file
Comment 3 Jorendc 2013-04-08 16:22:38 UTC
Created attachment 77611 [details]
exported pdf file
Comment 4 Jorendc 2013-04-08 16:23:37 UTC
priority:
Normal: does prevent you to make high quality work
High: higher then default "normal"
Comment 5 JO 2013-04-09 20:11:49 UTC
Created attachment 77687 [details]
Testfiles to detect the Hyperlinkmistake
Comment 6 JO 2013-04-09 20:25:21 UTC
(In reply to comment #4)
> priority:
> Normal: does prevent you to make high quality work
> High: higher then default "normal"


HIGH

kind regards 
JO
Comment 7 JO 2013-04-20 19:08:38 UTC
Hello,
the same mistake also appears, if a Word-DOC or DOCX -Document was saved in Libre Office as a Word-dodument with the suffix doc(Word 2003)and docx (Word 2007/2010)!
Kind regards
JO
Comment 8 Carlo Strata 2013-05-10 11:56:58 UTC
Environment:
- LibreOffice 4.0.3.3, Win32 build, ita GUIed;
- Windows 8, 64 bit, ita GUIed;
- Adobe Acrobat Reader, XI, 11.0.2, Win32, ita GUIed.

I have just red all this issue and opened the attachments.

I have noted that the tooltips (yellow labels appearing "on mouse over") on each link in the attached exported pdf file (but the same things happen on a new 4.0.3.3 exported pdf) are quite different in structure (only in the pdf file!):

- link http://www.ümlaut.de has the following tooltip:
-- file:///home/joren/Downloads/http://www.ümlaut.de

- link http://www.libreoffice.org has the following tooltip:
-- http://www.libreoffice.org

Maybe this can help?

Have a nice day,

Carlo

p.s. I came in this issue because I find out a new pdf exported document with link error and I look if this issue may concern or not. See here:
http://nabble.documentfoundation.org/4-0-3-3-non-fixed-bug-Link-with-a-space-Pdf-export-error-20-characters-space-ones-exported-as-2520-o-td4054826.html

But seeing that different pdf tooltip I decide, for the moment, to open a new case (issue).
Comment 9 Carlo Strata 2013-05-10 12:22:21 UTC
In relation with my previous comment I had opened the Issue 64428.

Carlo
Comment 10 retired 2014-08-11 08:26:42 UTC
Persisting with Version: 4.4.0.0.alpha0+
Build ID: aa0e3701aad1a8a955773e869d9a6b59eac51e72
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-08-10_06:59:50

Link with umlaut (ä,ö,ü) goes nowhere while other link is fine when visiting links via exported PDF file.
Comment 11 QA Administrators 2015-09-04 02:49:09 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.0.5 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-09-03
Comment 12 Buovjaga 2015-11-30 13:09:42 UTC
The problem is still in 5.0.3, but fortunately it is fixed in 5.1/5.2 at least.

To all: please retest when 5.0.4 comes out in a few weeks.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: a7c3a2a9be83686657c06f37d521f9f6d2004ddd
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-28_04:39:18
Locale: fi-FI (fi_FI)