Bug 63233 - EDITING FORMATTING: Using "Text to columns" causes crash
Summary: EDITING FORMATTING: Using "Text to columns" causes crash
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-07 14:22 UTC by MichaelH
Modified: 2013-05-04 06:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MichaelH 2013-04-07 14:22:57 UTC
Spreadsheet app crashes after trying to convert a cell of text, to columns of data using menu item Data -> Text to columns...

Reproduce:
1) Open a new spreadsheet.
2) Copy the following text: 02/17/2013 15:05:09 18546
3) Paste text into a cell (Ctrl-v)
4) Select from menu: Data -> Text to columns...

Actual Results:
Crash. Application disappears. 
Info: soffice.bin was killed by signal 6 (SIGABRT)

Expected Results:
The one cell of text converted to two columns of data: Column 1 would be date and time; Column 2 would be the numeric value 18546 (from example above). 

Build Date & Platform:
Gnome desktop Version 3.6.3
Fedora 18, kernel: 3.8.4-202.fc18.x86_64 #1 SMP
LibreOffice Fedora Build ID: 3.6.5.2-8.fc18

Additional Builds and Platforms:
Also occurred with a previous recent build of LibreOffice.


Note: Issue originally discovered when copying data from a web page, then using EDIT -> Paste Special, to paste and convert to column data and properly format the date field. Have narrowed issue down to the "Text to columns..." menu function.
Comment 1 Arnaud Versini 2013-04-07 20:11:43 UTC
Can't reproduce this on Ubuntu 64 with master and LibreOffice 4.0.1
Comment 2 Julien Nabet 2013-04-11 19:39:49 UTC
MichaelH: could you give a try to a newer version? Last 3.6 version is 3.6.6 and last 4.0 version is 4.0.2
Comment 3 MichaelH 2013-04-16 10:38:56 UTC
I opened a bug report with Red Hat they determined it was related to a gtk2 theme that I was using (Bluecurve). I changed back to the default gtk theme Adwaita and now pasting data does not crash the application.
Comment 4 Julien Nabet 2013-05-04 06:12:33 UTC
MichaelH: thank you for your feedback, I just update the status to NOTOURBUG