Download it now!
Bug 63245 - Problem Inserting text+bitmap document
Summary: Problem Inserting text+bitmap document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86 (IA32) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Insert-File-Content
  Show dependency treegraph
 
Reported: 2013-04-08 00:48 UTC by David Ronis
Modified: 2019-05-04 19:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
An example of a zamzar PDF->ODT file that doesn't insert properly. (688.43 KB, application/vnd.oasis.opendocument.text)
2013-04-08 00:48 UTC, David Ronis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Ronis 2013-04-08 00:48:55 UTC
Created attachment 77568 [details]
An example of a zamzar PDF->ODT file that doesn't insert properly.

I have a project in which my coworkers send me pieces (preferably in .odt compatible format) and I incorporate them into a unified document.   The worst part of what I have to do is to deal with PDF files
(The way I've dealt with this is to open them in draw and then copy&paste each page into my ODT document).

Recently I've discovered zamzar.com, which seems to convert PDF->ODT in one shot.   Indeed, when I open the resulting ODT file in LO it looks right.    Now here's my problem:

I go to my master document (or an new, empty, one for that matter) and try to insert the converted file
as Insert->file the text parts are inserted, but it seems that all the graphics parts (as bitmaps I think) are not.

So again:  opening the file to be inserted works as expected, but trying to insert it into another document doesn't work quite right.

I'll attach the document in question.

What would be better would be a hack that allows LO to insert a multipage PDF file, instead of having to copy  and paste each page manually.
Comment 1 Jorendc 2013-04-08 16:44:52 UTC
hi,

Thanks for reporting.

Tested using Linux Mint 14 x64 with LibreOffice 4.0.2.2:

* Open (file > open) attached file using LibreOffice
Behavior: images are displayed well

* Open new text document
* File > Insert
* Select attached file
Behavior: images aren't imported correctly.

* Open attached file again using the File > Open... way
* Select All (ctrl+A)
* Copy (ctrl+C)
* Open new text document
* Paste (ctrl+V)
* Save file as odt (for example ThisFile.odt)
* Open new text document
* Insert > File
* Select created odt file (ThisFile.odt)
Behavior: imported correctly.

I can't determine the cause of this "bug", but it _could_ be a bug in the used conversion too off course.

(In reply to comment #0)
> What would be better would be a hack that allows LO to insert a multipage
> PDF file, instead of having to copy  and paste each page manually.
Please file a seperate enhancement request for this.

I mark this bug as NEW because I can reproduce this bug, but it could be never get fixed (unless this is a bug of LibreOffice of course).

Following [1] I mark this bug as Minor Medium.
Minor: does make it substantially harder to make high quality work
Medium: default priority for minor bugs.

Kind regards,
Joren

[1] https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 2 A (Andy) 2015-02-26 19:59:33 UTC
Reproducible with LO 4.4.1.2, Win 8.1


(In reply to Jorendc from comment #1)
...
 
> * Open new text document
> * File > Insert
> * Select attached file
> Behavior: images aren't imported correctly.

INSERT -> DOCUMENT
Result: Images are not imported correctly.
 
> * Open attached file again using the File > Open... way
> * Select All (ctrl+A)
> * Copy (ctrl+C)
> * Open new text document
> * Paste (ctrl+V)
> * Save file as odt (for example ThisFile.odt)
> * Open new text document
> * Insert > File
> * Select created odt file (ThisFile.odt)
> Behavior: imported correctly.

Result: Images are still not there.
Comment 3 tommy27 2016-04-16 07:22:27 UTC Comment hidden (obsolete)
Comment 4 Thomas Lendo 2019-05-04 19:15:14 UTC
I can't reproduce this bug.

Version: 6.3.0.0.alpha0+
Build ID: 98630a0bd49bd80652145a21e4e0d0ded792b36b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-04_04:44:35
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

I close this bug as WORKSFORME.

If you can still reproduce it, please reopen as NEW.