Bug 63256 - [Template Manager][UI] missing option to show available templates as list (not preview/icons) in new template manager
Summary: [Template Manager][UI] missing option to show available templates as list (no...
Status: RESOLVED DUPLICATE of bug 104154
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2013-04-08 09:29 UTC by hp.web
Modified: 2016-11-25 08:38 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hp.web 2013-04-08 09:29:49 UTC
Problem description: 

I'm not sure, whether this is the right place to submit my problem.

For my purposes the new template manager is a big step backword in usability. Before I had a list where I could see nearly all my templates with one view, and it was very easy for me to choose one. Now I have to scroll quite a bit to find the fitting template. 

So I would very much appreciate an option to display my templates as a list again.

If this was the wrong list, please let me know where to submit my problem.

And thanks a lot for your work with libreoffice. I'm very glad to have such a good free office.

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: All
Version: 4.0.1.2 release
Comment 1 Jorendc 2013-04-08 18:43:57 UTC
I can confirm this option is now gone.

@Rafael: I saw your many fixes regarding the template manager lately, therefore I place you in CC.

Kind regards,
Joren
Comment 2 Jorendc 2013-04-09 10:39:09 UTC
(In reply to comment #1)
> I can confirm this option is now gone.

More particularly: the old template manager showed as a kind of 'list'. This wasn't a feature, but it looked like on. Therefore it loosed its functionality as such.
 
Kind regards,
Joren
Comment 3 oliver 2014-01-05 18:27:57 UTC
I can confirm this bug is still present in LO 4.1.2. It would be really great to have an option to switch between both views...

I'm using templates quite often and have many of them, so this new layout is absolutly horrible if you search for a particular one with a name longer than 10...12 letters.

Thanks for your hard work on this project!
Comment 4 gooly 2014-11-17 20:34:00 UTC Comment hidden (me-too)
Comment 5 Al Maloney 2015-01-11 14:53:57 UTC
Is there any hope that we will have the option of using a list of templates?

The icons use up too much space.
Navigation is more difficult with the current icon display.
Comment 6 Cor Nouws 2015-01-11 14:58:33 UTC
I would be in favour.
Let's see what others think.
Comment 7 KST 2015-01-19 15:14:04 UTC
First of all I'd like to thank you for the work on LibreOffice. We have changed over to LibreOffice 4.2 recently and are (almost) happy - just one hang-up: the template manager.

I would also be in favour of a template list, preferably all templates (Writer, Calc, Impress) in one List. 

Using the current template viewer with long template names is a hassle.

We have quite a number of templates in use and its not always clear to the user whether these are tables or documents. We sort our templates into folders, depending on the function/product they are required for.

I hope that there is a solution for this soon.
Comment 8 Samuel Mehrbrodt (CIB) 2016-06-03 12:55:37 UTC
So we are redesigning the template manager currently with some ux changes.
Would you please test the daily version [1] and check whether you still need the list view?

Note that we improved filtering and searching.
So if this does not work for you, please describe your use case (why you would need a list view).

[1] http://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/
Comment 9 Al Maloney 2016-06-03 13:52:06 UTC
Using Version: 5.3.0.0.alpha0+
Build ID: b6056eabfa8583d687165e3f9656cd322230829c
CPU Threads: 4; OS Version: Mac OS X 10.11.5; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-06-02_05:15:59
Locale: en-CA (en.UTF-8)

on Mac OS X 10.11.5

I prefer a list view because the icons use too much space requiring too much scrolling.

Also, the list view would provide more options to choose from in each window.

How do the icons make searching and choosing better than a list?
Comment 10 Heiko Tietze 2016-06-03 14:03:22 UTC
(In reply to Al Maloney from comment #9)
> How do the icons make searching and choosing better than a list?

If you search by description the list together with a preview is the perfect control. But most people would have the picture in mind how the template look. And that's better supported by several images - the icon view. So I'd say either the developers allow to switch from icon to list view or WONTFIX.

Have you taken a look at the latest build? The filter and search options are very handy and may help you as well.
Comment 11 Al Maloney 2016-06-03 15:26:40 UTC
(In reply to Heiko Tietze from comment #10)
> (In reply to Al Maloney from comment #9)
> > How do the icons make searching and choosing better than a list?
> 
> If you search by description the list together with a preview is the perfect
> control. But most people would have the picture in mind how the template
> look. And that's better supported by several images - the icon view. So I'd
> say either the developers allow to switch from icon to list view or WONTFIX.
> 
> Have you taken a look at the latest build? The filter and search options are
> very handy and may help you as well.

Yes. I have looked at it in the version noted in my post.
The changes are promising.
Although not what I had in mind, they are an improvement if I am using them properly.

First I select the application eg Document=Writer, Spreadsheet=Calc, etc.
Then I select a Category.
This produces a screen with fewer items which is easier to navigate.

I think this is workable for me.

One suggestion - If a category is empty for a given application, then it is suppressed from the list of choices for that application.

Thank you to all who are working on this!
Comment 12 Samuel Mehrbrodt (CIB) 2016-06-17 09:11:12 UTC
@Al Maloney, thanks for your feedback! Good to hear that it works for you.

Closing this as it doesn't fit in the design of the revamped template manager.
Comment 13 Brad Richards 2016-08-09 11:34:39 UTC
I would like to request reconsideration of this bug. The statement "people would have the picture in mind how the template look" depends on which users you are familiar with. Certainly it does not fit our use case.

We use LibreOffice in a company setting. The company uses an ERP system that generates customer correspondence. This consists of numerous templates, multiplied by numerous languages. End users never see the templates at all, because the ERP system selects the template needed, fills in the blanks, and presents the document to the user for any final changes.

Maintaining the templates is handled by IT staff, and is *painful*. There are several dozen templates, the template manager takes several seconds to open (generating the little preview pictures takes time). If the templates are opened across the network, this takes about 15 seconds; if they are copied to the local machine, it still takes about 3 seconds. Added to this is the need to scroll, because the preview pictures prevent a compact display.

Since it is impossible to select and open more than one template at a time, this delay is multiplied by each template we need to access. Yesterday, I had to open and adapt approximately 60 templates. This was a truly painful experience. A list view and multi-select would have been much more efficient.

There is just no reason to change from the standard file-browser interface. People who want preview pictures can get them. People who want a list, can get a list. Features like multi-selection are standard. There is simply no reason to re-invent the wheel.

If you do not wish to allow a list view and multi-selection in the template manager itself, then - at a minimum - you should restore the previous functionality outside the template manager: allow template files to be opened for editing from the file browser, via the context menu. That way, people who want to work with many templates efficiently would have an alternative.
Comment 14 kae 2016-08-09 12:01:31 UTC
I have to add my voice to Brad's. He makes the points very well, but in summary the new template manager is far less convenient to use.
Comment 15 Cor Nouws 2016-08-09 12:06:26 UTC
Hi Brad,

(In reply to Brad Richards from comment #13)
> I would like to request reconsideration of this bug. The statement "people
> would have the picture in mind how the template look" depends on which users
> you are familiar with. Certainly it does not fit our use case.

I agree that it's not good for all use cases when there is no list view, with all the normal functions it offers, available.
Personally i prefer that too - just much faster to handle..

> ...
> Maintaining the templates is handled by IT staff, and is *painful*. There
> ...

I would expect there are smarter ways for IT staff then using the template manager. Did your colleagues (for example) try the new File>Templates>Open Template ?

ciao - Cor
Comment 16 Cor Nouws 2016-08-10 10:32:58 UTC
it looks as if https://bugs.documentfoundation.org/show_bug.cgi?id=61471#c22 brings in another argument.
Comment 17 Darek 2016-08-22 06:54:14 UTC
Hi,

is it possible to create extension that will enrich existing Template Manager or create completely new one?

I'd like to have features that allow to display document template metadata as tooltip, and to search by them in templates (and of course list view of templates).


Regards
Darek
Comment 18 Robinson Tryon (qubit) 2016-08-25 05:39:09 UTC Comment hidden (obsolete)
Comment 19 Samuel Mehrbrodt (CIB) 2016-11-25 08:38:18 UTC
So I've gone ahead and created an easy hack for this: bug 104154.
Think it's useful to have for users that use templates heavily. That's the target group of the template manager in the end.

Closing this one in favor of bug 104154.

(In reply to Darek from comment #17)
> is it possible to create extension that will enrich existing Template
> Manager or create completely new one?

Sure it is. But you can also enhance the built-in one.

*** This bug has been marked as a duplicate of bug 104154 ***