Bug 63324 - Headless conversion fails: Error: Please reverify input parameters...
Summary: Headless conversion fails: Error: Please reverify input parameters...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Commandline Format-Filters
  Show dependency treegraph
 
Reported: 2013-04-09 16:32 UTC by gdwarner
Modified: 2020-04-04 23:15 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
docker config file (1.18 KB, text/plain)
2014-04-23 01:07 UTC, Ana Nelson
Details
libreoffice draw file which demonstrates issue (8.22 KB, application/vnd.oasis.opendocument.graphics)
2014-04-23 01:07 UTC, Ana Nelson
Details
console bt (8.37 KB, text/plain)
2015-11-29 09:49 UTC, Julien Nabet
Details
console bt (6.59 KB, text/plain)
2015-11-29 13:44 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gdwarner 2013-04-09 16:32:09 UTC
Here is the command I'm running:

[gwarner@arch system_test]$ soffice --headless --convert-to html:HTML test_plan.doc

convert /home/gwarner/p4/_sw/test/system_test/test_plan.doc -> /home/gwarner/p4/_sw/test/system_test/test_plan.html using HTML
Error: Please reverify input parameters...


System Details: Archlinux x86_64

Exporting from the GUI (Save As... -> html) works fine.

When I run the command on a machine with Ubuntu x86 with Libreoffice 3.6.2.2, it works as intended.
Comment 1 Laubrino 2013-05-03 15:44:11 UTC
Similar problem here:

soffice.bin --headless --convert-to pdf document.docx
convert /root/document.docx -> /root/document.pdf using writer_pdf_Export
Error: Please reverify input parameters...

and no document is created.

If I run it without the "--headless", it works! The pdf document is created.

LibreOffice 4.0.1.2
Debian linux 7.0
uname: Linux xxx 3.2.0-4-amd64 #1 SMP Debian 3.2.41-2 x86_64 GNU/Linux
Comment 2 Michael Meeks 2013-05-06 12:58:25 UTC
Riccardo - are you aware of this one ? :-)
Comment 3 Laubrino 2013-05-06 13:19:51 UTC
I did some more research. I have libreoffice 3.5 and 4.0 installed on the same linux (Ubuntu 12.04). 

With libreoffice 3.5 it works and the pdf is generated in headless mode. With 4.0 version it doesn't work in headless mode.

It happens only with the one particular docx document (which I cannot share for privacy reasons, unfortunately)
Comment 4 Laubrino 2013-05-06 13:33:56 UTC
And I also tested on Windows in headless mode and it works in 3.6 and 4.0 as well.
Comment 5 Riccardo Magliocchetti 2013-05-06 16:22:46 UTC
(In reply to comment #2)
> Riccardo - are you aware of this one ? :-)

Never used / touched convert-to but i'll try to take a look at this later today.
Comment 6 Riccardo Magliocchetti 2013-06-06 20:12:30 UTC
(In reply to comment #0)
> Here is the command I'm running:
> 
> [gwarner@arch system_test]$ soffice --headless --convert-to html:HTML
> test_plan.doc

Can you share your doc file please?
Comment 7 Florian Manschwetus 2013-07-13 19:04:14 UTC
This also doesn't work for odg to svg
Comment 8 Florian Manschwetus 2013-07-13 19:05:09 UTC
Sorry forgot to mention lo 4.1.0.2 linux amd64
Comment 9 Riccardo Magliocchetti 2013-07-14 12:33:32 UTC
(In reply to comment #8)
> Sorry forgot to mention lo 4.1.0.2 linux amd64

Thanks for confirming, but what we are tracking here is something document specific although the error libo is returning is pretty generic and possibly has nothing to do with parameters :) Please upload the broken document and post the exactly command line invocation you have tried.
Comment 10 Sergey Pashinin 2013-08-12 12:13:00 UTC
I want to add that I have this bug. And it is not document specific but platform specific (Windows) for me.

I can not convert any doc/docx documents.

LO just writes something like:

Convert "D:/a.docx" -> "D:/a.docx"   (yes, same extension, but I wanted "pdf")
Error: Please reverify input parameters...

On GNU/Linux - everything is fine.

LO - 4.0.2, 4.1
Comment 11 Ana Nelson 2014-04-23 01:05:59 UTC
I am seeing this error, or one that acts just like it, on 4.1.3 on Ubuntu (in a Docker instance). I've also tested on 4.2 and it is still present (but 4.1.3 is the current version installed via apt-get).

docuser@f475eb7a9f39:~$ libreoffice --version
LibreOffice 4.1.3.2 410m0(Build:2)

png conversion works just fine:

docuser@f475eb7a9f39:~$ libreoffice --headless --convert-to png example.odg 
convert /home/docuser/example.odg -> /home/docuser/example.png using draw_png_Export
docuser@f475eb7a9f39:~$ ls
example.odg  example.png  libreoffice

But svg conversion fails:

docuser@f475eb7a9f39:~$ libreoffice --headless --convert-to svg example.odg 
convert /home/docuser/example.odg -> /home/docuser/example.svg using draw_svg_Export
Error: Please reverify input parameters...

I will attach my example odg file and Dockerfile, but any odg file seems to have this problem.
Comment 12 Ana Nelson 2014-04-23 01:07:13 UTC
Created attachment 97790 [details]
docker config file
Comment 13 Ana Nelson 2014-04-23 01:07:39 UTC
Created attachment 97791 [details]
libreoffice draw file which demonstrates issue
Comment 14 Ana Nelson 2014-04-23 01:12:39 UTC
... And if there's any debugging I can do, or anything else to help move this forward, please let me know. This is a very important feature for me.
Comment 15 Robert Niedosmialek 2014-05-23 13:16:51 UTC
Is there any progress on this bug as I have just come upon it in 4.2.4.2 version? I can save a ODP to SVG with the UI but from the command line it fails and it does not matter what ODP/PPT/PPTX I use.
Comment 16 Chris C 2014-07-07 22:03:10 UTC
This is still open on the current version on Ubuntu. Please notice the error: "Error: Please reverify input parameters..." it looks like it is a parsing error on the command line. It should not be difficult to fix.
Comment 17 Riccardo Magliocchetti 2014-07-08 07:18:17 UTC
(In reply to comment #16)
> This is still open on the current version on Ubuntu. Please notice the
> error: "Error: Please reverify input parameters..." it looks like it is a
> parsing error on the command line. It should not be difficult to fix.

Unfortunately it's not that simple, that message is printed for every exception raised.
Comment 18 Björn Michaelsen 2014-08-21 12:21:13 UTC Comment hidden (obsolete)
Comment 19 ciccibolli86 2015-02-05 16:13:36 UTC
Hello,

I came across the same problem. 
However, I found out that typing 'htm' instead of 'html' works fine.
So the workaround would be:
/Applications/LibreOffice.app/Contents/MacOS/soffice  --invisible --headless --convert-to htm t.rtf

I hope it will be useful.
Comment 20 Riccardo Magliocchetti 2015-02-09 08:43:03 UTC
(In reply to ciccibolli86 from comment #19)
> Hello,
> 
> I came across the same problem. 
> However, I found out that typing 'htm' instead of 'html' works fine.
> So the workaround would be:
> /Applications/LibreOffice.app/Contents/MacOS/soffice  --invisible --headless
> --convert-to htm t.rtf
> 
> I hope it will be useful.

Nice finding! Which version of libo was this? Thanks!
Comment 21 Sven Goossens 2015-03-19 09:01:43 UTC
Still fails on Ubuntu 14.04 with LibreOffice 4.2.7.2 420m0(Build:2)

empty.odg is an empty draw document, (open draw, save file --> empty.odg)

~/Desktop $ soffice --version
LibreOffice 4.2.7.2 420m0(Build:2)

~/Desktop $ soffice --headless --convert-to svg empty.odg 
convert ~/Desktop/empty.odg -> ~/Desktop/empty.svg using draw_svg_Export
Error: Please reverify input parameters...

Curiously, eps and pdf export do actually work.
Comment 22 Sven Goossens 2015-03-19 09:57:40 UTC
4.4.1.2 provides slightly more info (and still fails):

/home/me/Desktop $ /home/me/software/LibreOffice_4.4.1.2_Linux_x86-64_deb/DEBS/install/opt/libreoffice4.4/program/soffice --headless --version
LibreOffice 4.4.1.2 45e2de17089c24a1fa810c8f975a7171ba4cd432


/home/me/Desktop $ home/me/software/LibreOffice_4.4.1.2_Linux_x86-64_deb/DEBS/install/opt/libreoffice4.4/program/soffice --headless --convert-to svg empty.odg 
convert /home/me/Desktop/empty.odg -> /home/me/empty.svg using filter : draw_svg_Export
Error: Please verify input parameters... (SfxBaseModel::impl_store <file:///home/me/empty.svg> failed: 0xc10)

0xc10 means ERRCODE_IO_CANTWRITE if I am not mistaking. The throw seems to happen here:
http://docs.libreoffice.org/sfx2/html/sfxbasemodel_8cxx_source.html#l03134
Comment 23 Julien Nabet 2015-11-29 09:49:07 UTC
Created attachment 120870 [details]
console bt

On pc Debian x86-64 with master sources updated yesterday, I could reproduce the pb with svg (I haven't tested yet with html).

I attached bt + details of parameters.
It seems SVGFilter doesn't manage headless mode.
Comment 24 Julien Nabet 2015-11-29 10:08:17 UTC
Let's give it a try, first for svg with https://gerrit.libreoffice.org/#/c/20268/
Comment 25 Julien Nabet 2015-11-29 13:44:58 UTC
Created attachment 120876 [details]
console bt

I retrieved a bt for html part.
In fact, GetExportFormatNumberForTypeName returns GRFILTER_FORMAT_NOTFOUND.
But should we really be there? I mean it seems it exports a graphic file whereas I expected a html page.
Comment 26 Julien Nabet 2015-11-29 13:51:46 UTC
Since I'm stuck for html part, let's unassign.
Comment 27 Commit Notification 2015-12-01 09:16:34 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8f7fe77b9ffeb45f5765d9d8f45710956a3e73d3

tdf#63324: Fix convert for svg filter

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Commit Notification 2015-12-01 09:31:16 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d38f716970027cceb3f28c35a2f6dbe36554ae08&h=libreoffice-5-1

tdf#63324: Fix convert for svg filter

It will be available in 5.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Julien Nabet 2015-12-01 22:15:26 UTC
Patches were for svg part, so I remove targets.
For html part, no idea what to do, certainly someone will know.
Comment 30 QA Administrators 2017-01-03 19:55:00 UTC Comment hidden (obsolete)
Comment 31 publicface 2017-08-28 01:17:59 UTC
ubuntu 16.04 LibreOffice 5.1.6.2 10m0(Build:2)
Not positive I'm actually doing this right, but I do seem to be experiencing this issue.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

apb@yellow:/usr/local/src/greetonix/src$ /usr/lib/libreoffice/program/soffice.bin -env:UserInstallation=file:///tmp/libreoffice-1 --headless --nolockcheck --convert-to csv:Text \(encoded\):UTF8 --infilter=MS Excel 97:44,34,76,1,,1033,true,true,false,false KGI_Discontinued.xlsx
Error: source file could not be loaded
Error: source file could not be loaded
Error: source file could not be loaded
convert /usr/local/src/greetonix/src/KGI_Discontinued.xlsx -> /usr/local/src/greetonix/src/KGI_Discontinued.csv using filter : Text
Error: Please verify input parameters... (SfxBaseModel::impl_store <file:///usr/local/src/greetonix/src/KGI_Discontinued.csv> failed: 0xc10)
apb@yellow:/usr/local/src/greetonix/src$

apb@yellow:/usr/local/src/greetonix/src$ ll KGI_Discontinued.xlsx

-rw-rw-r-- 2 apb apb 88334 Aug 18 16:00 KGI_Discontinued.xlsx 

apb@yellow:/usr/local/src/greetonix/src$ file KGI_Discontinued.xlsx 
KGI_Discontinued.xlsx: Microsoft Excel 2007+
Comment 32 QA Administrators 2018-08-29 02:42:39 UTC Comment hidden (obsolete)
Comment 33 Timur 2020-04-03 08:24:49 UTC
Hello. Here, multiple users experienced this issue. But, last report was a while ago. 
I tested now in Windows and Ubuntu 18.04, all works (convert to PDF, SVG, PNG, HTML), even with older Lo 6.2.8.

So, I'll close as WorksForMe. If anyone still has an issue, feel free to set New with concrete example what fails. 
Here is a nice explanation with params: https://stackoverflow.com/questions/30349542/command-libreoffice-headless-convert-to-pdf-test-docx-outdir-pdf-is-not
Comment 34 a.mux 2020-04-04 23:15:25 UTC
Hi,

I know this is old but I just stumbled on this bug report while looking for a solution to a similar problem at https://github.com/ether/etherpad-lite/pull/3783#issuecomment-609097882.

In my case the problem was with quoting of the parameters when using via the shell vs when invoking via execve().

At least, I'd like to signal that publicface's message (https://bugs.documentfoundation.org/show_bug.cgi?id=63324#c31) has a problem of quoting BEFORE even triggering the real problem on libreoffice.


"Modern" version of his command shows a misleading error because of the wrong escaping:

$ libreoffice6.4 -env:UserInstallation=file:///tmp/libreoffice-1 --headless --nolockcheck --convert-to csv:Text \(encoded\):UTF8 --infilter=MS Excel 97:44,34,76,1,,1033,true,true,false,false KGI_Discontinued.xls
Error: source file could not be loaded
Error: source file could not be loaded
Error: source file could not be loaded
convert /tmp/KGI_Discontinued.xls -> /tmp/KGI_Discontinued.csv using filter : Text
Error: Please verify input parameters... (SfxBaseModel::impl_store <file:///tmp/KGI_Discontinued.csv> failed: 0xc10(Error Area:Io Class:Write Code:16))


That command should really have been:

$ libreoffice6.4 -env:UserInstallation=file:///tmp/libreoffice-1 --headless --nolockcheck --convert-to "csv:Text (encoded):UTF8" --infilter="MS Excel 97:44,34,76,1,,1033,true,true,false,false" KGI_Discontinued.xls
convert /tmp/KGI_Discontinued.xls -> /tmp/KGI_Discontinued.csv using filter : Text (encoded):UTF8
Error: Please verify input parameters... (SfxBaseModel::impl_store <file:///tmp/KGI_Discontinued.csv> failed: 0xc10(Error Area:Io Class:Write Code:16))


It still fails, but probably now it's a question of finding the right parameters for conversion.

In my case I was converting to HTML with "XHTML Writer File:UTF8", and using the right escaping solved the problem.