Bug 63352 - EDITING: Text Folding needed
Summary: EDITING: Text Folding needed
Status: RESOLVED DUPLICATE of bug 47746
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-10 04:35 UTC by Matthew B
Modified: 2015-03-07 05:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document how to hide / unhide (21.18 KB, application/vnd.oasis.opendocument.text)
2013-04-10 06:22 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew B 2013-04-10 04:35:48 UTC
please see the better formatted version here:
http://ask.libreoffice.org/en/question/2596/text-folding-pretty-please/


Request Summary:
For brain storming, outlining, studying, code writing, drafting documents, or helping the reader brief documents quickly, Folding text seems like a must! It makes those tasks (just for starters) a breeze. Please add folding text functionality to the next release or give advice on how to make add-on.

For folding text examples and explanation see:
Wikipedia uses text folding on their mobile site, notice it at http://en.m.wikipedia.org/wiki/Code_folding
Wikipedia claims it is used in many modern "text ediotrs", but those are like word pad and notepad++ and are not anything like a word processor/desktop publisher .
-
Explanation of text folding: Text folding allows a user to collapse one or more characters, sentences, paragraphs, etc, so that (though still existing in the document) it is not visisble, but is instead represented by a simple symbol (like a "+" or a "{...}"). Clicking on that simple simble will expand the text.
Why am posting this request on this forum:
Have been waiting for this feature in a decent word processor, but have only found it in one lightweight mac program and in script editors. I really need it to make my word processor more useful: studying, outlining, coding, etc. Don't like having to switch to different programs to do one task. Also, the programs which already offer this feature are EXTREMELY poor word processors. Wan't a program that can do both.

Please make an extension/add-on to add this feature, advise how to make the add-on, or incorporate it into the next release.

Detail of features that should be added to Libre Writer:
General Folding text (you know like in NotePad++) capability.

Different Modes of toggling Folded Text: MarginSymbol and/or Inline Summary

a. Margin Symbol - like NotePad++ (click plus in margin to expand, minus to fold)

b. Inline Summary-. This method will show a customized summary item which represents the hidden text. The hidden text can be shown/expanded by right clicking on the inline summary item > then clicking the context menu option "show all". Collapse the expanded text by right clicking on the text > then clicking on the context menu item "show summary".

Txt summary item may be either:    
 i.   PreDefined text (ex, "+", "note", "...", "Summary", a bullet).
 ii.  Auto Enumerated (ex "exhibit", "exhibit2", "par1", "par2").
 iii. Auto Summary of...
         text's First Paragraph,
         text's First Sentence, or
         until page full, but not more than 2 lines, & at least 1 line.
 iv.  Any Custom Text/Field, such as
        "(click to see examples and proofs)"  
        "Class Notes [Date]."

***In all instances***: 
    1. ability to format summary item (be it text or pic) like any other text or pic in the doc.
    2. ability to not allow or to allow the editing of the summary item.
    3. method indicating inlinetext is summarized (ex, highlight on mouse over)
In-Line Text Preview for embeded or linked documents. The embeded/linked document would be represented by a summary item. The summary item can be any user defined item (ex "{...}", a long or brief description, a bullet, or image), as in previous cases. But Writer should also give an additional option in the case of embedding or linking a document: the option to make any portion of the embeded/linked document the summary item, NOT allow any change to that summary item (except formatting), BUT update the summary item when the linked document/embedded document changes. Right clicking the summary item will give the additional option to open the document.

Outline View Of Doc. (similar to MS Word, folding capability of text) PS, MS Wrd does a bad job of this last time I checked...mainly due to... a lack of any format control in outline view.2.2.3.2.3.2.---3.3.--Blockquote-
              
Operating System: All
Version: 4.0.2.2 release
Comment 1 Rainer Bielefeld Retired 2013-04-10 06:22:11 UTC
Created attachment 77718 [details]
Sample Document how to hide / unhide

We never had something like that the way reporter wants.

I believe it's already everything in LibO what is required for that function. Attached sample333 has 3 Sections. Section2 is hidden by default (you can unhide in Navigator), Section1 Can be hidden by setting a Variable to "0", reappears when you change Variable from 0 to 1.

So I believe currently we need some "tips and tricks" how to do that "show or hide" in a more elegant way with a button, but for an expert that should be easy. If that exists, we can think about to make that function available in a more easy way, may be by an Extension or enhancing LibO functions.

May be someone can add such a function with some explications to ma sample, attach that one and obsolete mine? Explication can be added to the WRITE manual, and so we would have done a first step.
Comment 2 Rainer Bielefeld Retired 2013-04-10 06:25:52 UTC
Attention, because of "Bug 55814 - Condition for hidden section replaced by "0"" the sample document will not work with latest stable versions
Comment 3 tommy27 2013-08-26 12:48:29 UTC
(In reply to comment #1)
> Created attachment 77718 [details]
> Sample Document how to hide / unhide
> 
> We never had something like that the way reporter wants.
> 
> ... snip ....

so setting status to NEW

@Matthew B
are you happy with Reiner's workaround?
Comment 4 Owen Genat (retired) 2015-03-07 05:02:35 UTC

*** This bug has been marked as a duplicate of bug 47746 ***