Bug Hunting Session
Bug 63373 - [KDE] the X to close a floating toolbar only shows up when moving the mouse over it
Summary: [KDE] the X to close a floating toolbar only shows up when moving the mouse o...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-10 11:44 UTC by almos
Modified: 2015-04-01 14:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
toolbar.png (50.62 KB, image/png)
2014-07-25 22:04 UTC, almos
Details
Screenshot from LO 4.3.0.3 (58.11 KB, image/png)
2014-07-26 05:33 UTC, ign_christian
Details
Screenshot with pointer hover over "x" (62.05 KB, image/png)
2014-07-27 14:17 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description almos 2013-04-10 11:44:55 UTC
Is this a feature or a bug?
Comment 1 Adolfo Jayme 2013-04-10 16:03:47 UTC
In the future, please make your bug reports more detailed, there’s no character limit, this is not an SMS ;-)

For example, what’s your OS? Did you notice this problem in an earlier version of LibreOffice, or is this a regression in the 4.0.x series?
Comment 2 almos 2013-04-10 17:05:20 UTC
My OS is Linux (KDE 4.8.4), and AFAICT this happens only since the upgrade to 4.0. Currently I use 4.0.2.2 from Debian Experimental.
Comment 3 QA Administrators 2013-11-04 22:18:27 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 4 almos 2013-11-04 23:15:15 UTC
Ok, ok. I supplied the info, but forgot to change the status.

BTW in 4.1.1.2 it seems that the X is mostly drawn, except on the first time opening the given toolbar.
Comment 5 Joel Madero 2013-11-04 23:22:41 UTC
Please read full comment - correct status is UNCONFIRMED. Thanks
Comment 6 Dominique Boutry 2013-11-19 10:09:13 UTC
LibO 4.1.2.3 on Win7 :
- mouse over the X : full button drawing (border, background and cross)
- mouse not over the X : only the cross, drawn as 2 thin black lines over the medium grey of the top bar.

Just an hypothesis : maybe caused by the use of a theme with darker color for such top bars, resulting in a difficulty to distinghish the black cross ?
Comment 7 tommy27 2014-07-17 05:06:51 UTC
I see no issues with "X" buttons in floating toolbars using LibO 4.2.5.2 under Win7x64

if issue is still reproducible please post a screenshot.
otherwise mark it as RESOLVED WORKSFORME
Comment 8 almos 2014-07-25 22:04:26 UTC
Created attachment 103475 [details]
toolbar.png

(In reply to comment #7)
> I see no issues with "X" buttons in floating toolbars using LibO 4.2.5.2
> under Win7x64
> 
> if issue is still reproducible please post a screenshot.
> otherwise mark it as RESOLVED WORKSFORME

I'm truly delighted that none of the UI bugs I reported are reproducible on Windows.

/sarcasm off

Here is a screenshot demonstrating the issue. Initially the X is missing, it only appears once the mouse pointer moves over it.
Comment 9 tommy27 2014-07-26 01:02:04 UTC
thanks 4 screenshot.
it must be a Linux specific issue. I confirm it's not reproducible under Windows.
have you tried upgrading to 4.2.x and resetting the user profile?
https://wiki.documentfoundation.org/UserProfile
Comment 10 ign_christian 2014-07-26 05:33:11 UTC
Created attachment 103489 [details]
Screenshot from LO 4.3.0.3

Looks like dependent to some DE in Linux. 

Confirm that behavior with Ubuntu 12.04 x86 Gnome 3.4.2 since 3.6.7.2 (package from PPA & LO site has same result). "x" is present but black colored, so it looks like not present.
3.5.7.2 and 3.3.0.4 slightly better, the "x" is grey colored.

I don't know with package from Ubuntu repository.
Comment 11 retired 2014-07-27 11:58:03 UTC
So since ign Christian was able to confirm, setting to NEW. Although I'm not sure I do understand his screenshot, since I do not see any floating toolbar.

But for me in 14.04 and LO 4.2.4.2 all floating toolbars have the "x" to close them permanently showing. So somewhat unsure what to make of this.

Can someone clarify this? Maybe already fixed? If not, under which circumstances is this persisting?
Comment 12 ign_christian 2014-07-27 14:17:15 UTC
Created attachment 103546 [details]
Screenshot with pointer hover over "x"

Hi Foss.. I attach additional screenshot showing what it looks like if we hover the pointer to the "x" that is "hidden" in screenshot on comment 10.

I can confirm with Ubuntu 14.04 Unity and LO 4.2.4.2 (package from Ubuntu repository) that "x" not exist. Perhaps it's because HUD activated with that package & Unity activated (by default)

But in those screenshots I'm using Ubuntu 12.04 with Gnome. Unity disabled, no HUD.
Comment 13 ign_christian 2014-07-27 14:33:43 UTC
Looks like I misread this bug. Sorry all for the noise.. Please forget all my comments before.

I can't reproduce comment 8 with LO 4.2.6.2 on Ubuntu 12.04 x86. That "x" exist in "Table" floating toolbar.

Set back to UNCONFIRMED
Comment 14 tommy27 2015-01-18 10:56:23 UTC
@almos
please tell if you still see that bug with updated Linux O/S and LibO (current relases is 4.3.5.2)

I set status to NEEDINFO waiting for your feedback
Comment 15 almos 2015-01-18 15:37:29 UTC
In Debian Unstable the newest version is 4.3.3.2, which still has this problem. I don't know if I should dare to install 4.4.0-rc2 from Experimental.
Comment 16 Buovjaga 2015-01-21 06:43:15 UTC
No problem with floating toolbar Xes on Kubuntu 14.10
LibO Version: 4.3.3.2
Build ID: 430m0(Build:2)

Maybe you can try with a live USB or virtual machine of some KDE distro to see, if you can reproduce.
Comment 17 Buovjaga 2015-02-19 13:18:38 UTC
Any update on this? Have you tried 4.4?
Setting to NEEDINFO, while waiting for news.
Comment 18 QA Administrators 2015-04-01 14:52:35 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

-- The LibreOffice QA Team This NEEDINFO Message was generated on: 2015-04-01

Warm Regards,
QA Team