Download it now!
Bug 63384 - UI: No Layers shown when EDITING as OLE object in WRITER
Summary: UI: No Layers shown when EDITING as OLE object in WRITER
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-10 14:33 UTC by Rainer Bielefeld Retired
Modified: 2015-06-15 11:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (14.77 KB, application/vnd.oasis.opendocument.text)
2013-04-10 14:33 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-04-10 14:33:34 UTC
Created attachment 77748 [details]
Sample Document

Steps how to reproduce with server installation of "LibO  4.0.2.2 rc   -  German UI / German Locale  [Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)]"  {tinderbox: @6, pull time  2013-03-26 12:00(?)} on German WIN7 Home Premium (64bit) with newly created own user profile

1. Open attached text2.odt from LibO Start Center
2. Doubleclick small rectangle at the top
   > Draw OLE object will be opened for editing
   Expected: Layer cards visible for layer selection and editing
   Actual: Only |< < > >| arrow buttons to jump between the layer cards, but no
           Layers visible

When you click on the Layer's area right from arrow buttons, you will be asked to insert a new layer, after confirmation also the default layers will become visible.

After Save - Close - Reopen the same game, you will have to insert a new layer to get the existing ones visible.

Works fine if you insert a New DRAW Ole via menu 'Insert -> OLE object - Draw object).

Already in 3.3.3 and also in AOOo 3.4.0, so probably inherited from OOo.
Comment 1 Owen Genat (retired) 2013-11-30 04:12:45 UTC
I can confirm the behaviour described. Status set to NEW. Platform set to All/All. I opened the provided file under Crunchbang 11 x86_64 running:

- v3.3.4.1 OOO330m19 Build:401
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

Under both versions the Layout, Controls, and Dimension Lines tabs (layers) are not initially displayed. Inserting an additional layer (Layer4) does however cause the entire row of tabs (layers) to display. Behaviour is the same for drawings newly inserted as OLE objects under the two indicated versions that are then subsequently re-opened at a later point (as originally described).
Comment 2 QA Administrators 2015-04-19 03:20:23 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 3 Buovjaga 2015-06-15 11:37:29 UTC
Confirmed 3.3 was as described, but with the latest version the Layout, Controls, and Dimension Lines tabs are visible immediately.

Ubuntu 15.04 64-bit 
Version: 5.1.0.0.alpha1+
Build ID: a9286c302e96258f32d13fb66aced25750e82cd3
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-06-13_00:35:08
Locale: en-US (en_US.UTF-8)

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)