Bug 63513 - Crash after setting new default template via template manager
Summary: Crash after setting new default template via template manager
Status: RESOLVED DUPLICATE of bug 59812
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-13 20:38 UTC by Stefan Knorr (astron)
Modified: 2013-04-16 23:03 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2013-04-13 20:38:14 UTC
How to reproduce:

Prerequisite:
   If you are on Linux, make sure you have installed the presentation
   backgrounds for Impress.

1. Open LibreOffice
2. Open the Template Manager via File > New > Templates
3. Go to the Presentations tab
4. Open the Presentation Backgrounds folder
5. Single-click any of the files in the folder to select it
6. Click the Set as Default button in the toolbar
7. Close the Template Manager
8. In the menu, choose File > New > Presentation
=> Result: Crash

I can reproduce this on:
* my own Linux build (Open-SUSE 12.2, x86-64; ca. Apr 10, 2013)
* on a Windows tinderbox build (Windows 8, x86; Apr 8, 2013; tinderbox Win-x86@6)

* * *

It does seem to have something to do with the Presentation backgrounds itself, as the following cases don't lead to a crash:
* basic .ott file (= blank document with some text inserted) set as default 
  template for Writer
* basic .otp file (= same as above) set as default template for Impress

Also note that simply opening a presentation background from the template manager by double-clicking it does not lead to a crash.
Comment 1 Thomas van der Meulen 2013-04-15 19:00:04 UTC
Hello Stefan, It doesn't chrash for me bug it is laggy. 
tested running LibreOffice 4.0.2.2 on mac osx 10.8.3
Comment 2 Jorendc 2013-04-16 23:03:52 UTC
Hi Stefan,

Seems this is a dupe of Bug 59812. Because you don't need to apply it via the template manager. If you apply it via Impress itself, you can reproduce sometimes a crash too (or at least heavy performance issues).

Therefore I'm going to mark it as such. If that bug is fixed, and you still can reproduce this behavior, please feel free to REOPEN this bug :-). But I'm 99% sure this is due that bug.

Thanks for taking your time filing a bug report!

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 59812 ***