Download it now!
Bug 63525 - Macros: in macros with dialogs the use of the EndExecute function freezes libreoffice (in some circumstances)
Summary: Macros: in macros with dialogs the use of the EndExecute function freezes lib...
Status: RESOLVED DUPLICATE of bug 59484
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-14 12:37 UTC by pasqual milvaques
Modified: 2013-04-14 13:04 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
tescase to reproduce the problem (16.04 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-04-14 12:37 UTC, pasqual milvaques
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pasqual milvaques 2013-04-14 12:37:27 UTC
Created attachment 77947 [details]
tescase to reproduce the problem

Problem description: 
I program complex macros with complex dialogs in libreoffice. I have found that if you launch from a macro a complex dialog which has interaction with the document (changing values of the cells in a spreadsheet, for example) the invocation of the endExecute function to close dialogs is capable to hang LibreOffice. 
The probabibility for this to happen seems to be related to the complexity of the dialog, with small dialogs doesn't happen but as more big is the dialog more probable is the error to happen.
if the dialog doesn't interact with the document the problem doesn't appear (as far as I know)
I have seen the problem in Windows xp and Windows 8, I have not tested it in linux still
I have seen the problem in libreoffice 4.0.2 and 3.6.5
I attach a testcase which opens and closes a dialog 10 times. there is a button to do it with a simple dialog where the problem probably will not happen and a button for doing it with a complex dialog where the problem happen normally in the first iteration

Steps to reproduce:
1. open the testcase file
2. click the button "Launch TestCase (simple dialog)". the simple dialog will try to open and close 10 times and the cell of the left will show the iteration number
3. click the button "Launch TestCase (complex dialog)". the complex dialog will try to open and close 10 times and the cell of the left will show the iteration number

Current behavior:
Libreoffice freezes when trying to close the complex dialog programmatically in the step 3 (normally in the first try)

Expected behavior:
Libreoffice showing and closing the complex dialog 10 times. the tescase could be repeated and infinite number of times withot hanging
              
Operating System: Windows 8
Version: 4.0.2.2 release
Comment 1 pasqual milvaques 2013-04-14 13:02:05 UTC
tested in linux (fedora 18, libreoffice 3.6.5) and the problem doesn't reproduce. seems a windows specific issue
Comment 2 pasqual milvaques 2013-04-14 13:04:44 UTC

*** This bug has been marked as a duplicate of bug 59484 ***