Bug 63527 - [64-bit] RTL and complex script support are completely broken
Summary: [64-bit] RTL and complex script support are completely broken
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-14 16:09 UTC by Emir Sarı
Modified: 2013-06-21 16:33 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot comparing 4.1 and 4.0.2 (129.65 KB, image/png)
2013-04-14 16:39 UTC, Emir Sarı
Details
screenshot (1.49 MB, image/png)
2013-04-14 18:16 UTC, Don't use this account, use tml@iki.fi
Details
Screencapture working good (230.99 KB, image/png)
2013-05-07 12:21 UTC, abdulmajeed
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı 2013-04-14 16:09:08 UTC
It is not possible to type any kind of RTL or complex script, including Arabic, Hebrew and Runic scripts. 

Steps to reproduce:

Open LO 64-bit
Change the layout to a complex or RTL script
Randomly type something

Expected behaviour: 
Nicely rendered text

Actual behaviour:
White spaces and some random decimals.
Comment 1 Don't use this account, use tml@iki.fi 2013-04-14 16:29:42 UTC
Hmm, but if you leave out the "Change the layout to a complex or RTL script" (which means what exactly?) step, what happens then? At least in my very light testing, just by changing to an Arabic keyboard layout, I could enter Arabic, and as far as I could see the letters exhibited the expected complex behaviour, like changing shape when joining with surrounding letters. (But of course, I have no knowledge of Arabic, so there might well have been errors. But at least I did not see "white space and random decimals".)

You need to give more detailed reproduction instructions.
Comment 2 Emir Sarı 2013-04-14 16:39:13 UTC
Created attachment 77951 [details]
Screenshot comparing 4.1 and 4.0.2

Here you can see a side to side comparison of what happens when I try to type complex scripts with LO.

Here's how to reproduce:
1. Open LO Writer 
2. Switch to a RTL keyboard layout, (Arabic, Hebrew etc.)
3. Make sure that Complex Scripts are enabled from Preferences
4. Type

Version: 4.1.0.0.alpha0+
Build ID: 092bc9b54c5b091d517315b61cbc0aa53d12737
Comment 3 Don't use this account, use tml@iki.fi 2013-04-14 18:16:05 UTC
Created attachment 77953 [details]
screenshot

Well, this screenshot is what I get it I just open the daily build of 64-bit LO, open Writer, switch to Arabic keyboard layout, and type the letters "arabic" ;)
Comment 4 Don't use this account, use tml@iki.fi 2013-04-14 18:22:37 UTC
Why is says "Hindi" at the bottom I have no idea. Ah, that seems to be the default for "LibreOfficeDev>Preferences>Language SettingsLanguages>Default languages for documents>CTL". (Why such a setting is even needed, and why it has to be separate for "Western" and "CTL", no idea. Couldn't there just be one "default language for document"?)
Comment 5 Emir Sarı 2013-04-14 18:39:31 UTC
It seems like a font issue. 

With font Arial Unicode MS, there is no problem. If the default RTL font is set to Times New Roman or something else, and LO is "expected" to fall back to the nearest? RTL font, it switches to Lucida Sans. and I get white spaces, clipped text, and not connecting letters. Geeza Pro does not even work, hell, it's the default OS X RTL font. 

But I must indicate that either font works fine when pasted into LO from another software. 

RTL display on LO OS X is really buggy, even with 32-bit LO I can't get connected letters unless I set the default RTL font to Geeza Pro.
Comment 6 Don't use this account, use tml@iki.fi 2013-04-15 11:04:53 UTC
Do we really want to use the keyword "regression" for an experimental pre-pre-alpha build of software we have no idea whether it is going to be "released" (by the TDF) even?
Comment 7 Emir Sarı 2013-04-17 15:10:44 UTC
@Tor,

Could this release be nominated for a possible 4.1 release? If so, us QA guys will have to work harder as it seems. ;-)

About the bug, could you please confirm the font issue?

Best regards,
Emir
Comment 8 abdulmajeed 2013-05-07 12:21:43 UTC
Created attachment 78983 [details]
Screencapture working good

test on master with enable core-text

it's working with Arabic there is no problem i have tried most of the fonts
Comment 9 Thomas Hackert 2013-06-21 16:30:55 UTC
Hello Emir, Tor, abdulmajeed, *,
@abdulmajeed: Do I understand your comment 8 right, that this bug is fixed in the meantime? If so: Would you be so kind to close it then, please?
Comment 10 Emir Sarı 2013-06-21 16:33:06 UTC
Tested with the latest master, and everything seems fine. 

Closing this bug.