Download it now!
Bug 63550 - UI CRASH: Navigator becomes unresponsive in .odg with 100000 shapes
Summary: UI CRASH: Navigator becomes unresponsive in .odg with 100000 shapes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-15 11:42 UTC by Rainer Bielefeld Retired
Modified: 2015-06-20 16:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-04-15 11:42:28 UTC
Steps how to reproduce [Reproducible] with parallel Dev-installation of  "Version 4.1.0.0.alpha0+ (Build ID: 049ce78144650d92eb6bd73292868f73d37c901) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-03-29_23:59:42" ENGLISH UI / German Locale on German WIN7 Home Premium (64bit) with LODev/4 Masters User Profile:

1. Open Attachment 66918 [details] for Bug 54722 (will take 2 minutes or so)
2. Activate Docked navigator if necessary
3. In Navigator Heading: activate 'Show all Shapes'
4. Expand all Sheets in Navigator, Starting with Sheet 1
5. Collapse all Sheets in Navigator, Starting with Sheet 1 
   After third run or so LibO stops responding,
   I terminated process after 10 minutes.	

I also see this in AOOo 4., os might be inherited from OOo.
I will do tests with stable versions later
Comment 1 Jorendc 2013-04-15 12:44:54 UTC
I can reproduce this using Linux Mint 14 x64 with LibreOffice Version: 4.1.0.0.alpha0+ Build ID: 4b73d334a9c5d8ae1fe16b2cc04100b9f333595
Last commit that is included in my build: 
commit 4b73d334a9c5d8ae1fe16b2cc04100b9f333595a
Author: Stephan Bergmann <sbergman@redhat.com>
Date:   Mon Apr 15 10:38:01 2013 +0200

Therefore I mark this as NEW.

My UI doesn't freeze when expanding all the Sheets in the navigator, but when I try to close LibreOffice, I need to force-quit it.
Comment 2 Michael Meeks 2014-01-13 15:30:07 UTC
Presumably some silly N^2 operation in the navigator tree or somesuch. If a callgrind trace was generated for that - it'd be much easier to fix I guess.
Comment 3 Joel Madero 2015-05-02 15:42:43 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 4 Buovjaga 2015-06-20 16:44:44 UTC
Did 3 runs of expand & collapse and nothing happened. WFM.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)